View Issue Details

IDProjectCategoryView StatusLast Update
0024413LazarusWidgetsetpublic2014-09-12 08:54
ReporterVojtech Cihak Assigned ToZeljan Rikalo  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version1.1 (SVN) 
Summary0024413: Qt does not paint tbPushButtonDisabled
DescriptionQt4 does not paint tbPushButtonDisabled (it is painted as ...Normal). Other - tb...Hot, tb...Pressed, tb...Normal works well. I am sure it worked in past.

I tested on:
Chakra Linux - Laz. 41081, FPC 2.7.1, Qt 4.8.4, KDE 4.10.2
openSuSE - Laz. 40775, FPC 2.7.1, Qt 4.8.4, KDE 4.10.0

I tested Plastique, QtCurve and Oxygen.

I attached demo, there are enabled images and components (left column) and disabled (right column).

It works well with GTK2.
TagsNo tags attached.
Fixed in Revision41144
LazTarget-
WidgetsetQT
Attached Files

Relationships

related to 0026586 closedZeljan Rikalo ThemeServices return wrong state images for checkbox 

Activities

Vojtech Cihak

2013-05-10 16:59

reporter  

Zeljan Rikalo

2013-05-12 10:29

developer   ~0067663

Please test and close if ok.
Note that this is an Qt bug because it does not set proper palette for disabled pushbutton control. Now, we are setting correct QPalette.

Vojtech Cihak

2013-05-12 12:53

reporter   ~0067667

I tested with r. 41148, themes Plastique, Cleanlooks, QtCurve and Oxygen. Works well. Thanks.

Issue History

Date Modified Username Field Change
2013-05-10 16:59 Vojtech Cihak New Issue
2013-05-10 16:59 Vojtech Cihak File Added: tbPushButtonDisabled.7z
2013-05-11 09:28 Zeljan Rikalo Assigned To => Zeljan Rikalo
2013-05-11 09:28 Zeljan Rikalo Status new => assigned
2013-05-12 10:29 Zeljan Rikalo Fixed in Revision => 41144
2013-05-12 10:29 Zeljan Rikalo LazTarget => -
2013-05-12 10:29 Zeljan Rikalo Note Added: 0067663
2013-05-12 10:29 Zeljan Rikalo Status assigned => resolved
2013-05-12 10:29 Zeljan Rikalo Resolution open => fixed
2013-05-12 12:53 Vojtech Cihak Note Added: 0067667
2013-05-12 12:53 Vojtech Cihak Status resolved => closed
2014-09-12 08:54 Zeljan Rikalo Relationship added related to 0026586