View Issue Details

IDProjectCategoryView StatusLast Update
0024439FPCCompilerpublic2013-05-17 03:13
ReporterMartin Friebe Assigned ToPaul Ishenin  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platformw32OSwin 
Target Version3.0.0Fixed in Version3.0.0 
Summary0024439: dynamic array not always initialized
Descriptionusing rev 24475 the below fails. It works using 2.6.0

dynamic types (such as TDynIntArray ) should be initialized, but with 2.7.2 (inspecting the below in the debugger) they are not initialized.

Checking in the debugger it looks like VarStatIntArray2A[5] is not initialized.

Additional Informationprogram Project1;

type
  TDynIntArray = Array of Integer;

procedure Foo;
var
  VarStatIntArray2A: Array [5..9] of TDynIntArray;
begin
  SetLength(VarStatIntArray2A[5],3);
end;

begin
  Foo;
end.
TagsNo tags attached.
Fixed in Revisionr24522
FPCOldBugId0
FPCTarget
Attached Files

Activities

Paul Ishenin

2013-05-17 03:13

developer   ~0067721

Please test and close if ok.

Issue History

Date Modified Username Field Change
2013-05-16 19:40 Martin Friebe New Issue
2013-05-16 19:48 Jonas Maebe Assigned To => Paul Ishenin
2013-05-16 19:48 Jonas Maebe Status new => assigned
2013-05-17 03:13 Paul Ishenin Fixed in Revision => r24522
2013-05-17 03:13 Paul Ishenin Note Added: 0067721
2013-05-17 03:13 Paul Ishenin Status assigned => resolved
2013-05-17 03:13 Paul Ishenin Fixed in Version => 2.7.1
2013-05-17 03:13 Paul Ishenin Resolution open => fixed
2013-05-17 03:13 Paul Ishenin Target Version => 2.8.0