View Issue Details

IDProjectCategoryView StatusLast Update
0024475LazarusIDEpublic2019-04-22 19:33
ReporterMartin Friebe Assigned ToJuha Manninen  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Platformw32OSwin 
Summary0024475: Object Inspector contineously flashing vertical line (empty hint)
DescriptionNew Project ? Application.
Add a TButton to the form.
In the OI scroll the property "ParentShowHint" into view.

Place mouse over the property name (OI left column).
Wait a second

A vertical line briefly appears (just a flash). IT does keep doing so, as long as the mouse is in place.

It may be an empty hint, or a hint with zero width
TagsNo tags attached.
Fixed in Revision
LazTarget-
WidgetsetWin32/Win64
Attached Files

Relationships

related to 0020185 closedPaul Ishenin W32: IDE Hint trigger it's own hiding (Regression?) =>: Debug hints do not show for some values 

Activities

Paul Ishenin

2013-06-23 11:38

manager   ~0068453

Can't reproduce. Please give me more details. Maybe it is already fixed.

Martin Friebe

2013-06-26 11:18

manager   ~0068546

It still happens. For some reason my Windows does send a WM_MOuseMove (to the html control (I use TurboPowerIPro). This is despite the hint is not under the mouse, and the mouse has not moved

Martin Friebe

2013-06-26 11:35

manager   ~0068547

This may be related to 0020185 Even though It did not seem that the hint was extended to be under the mouse.

Martin Friebe

2013-06-27 21:05

manager   ~0068613

It also depends on where the OI is, If I move it away from the left of the screen, then all works fine.

I can only guess, that when the hint window is created, it has a default position, and even though it is not drawn there, this may be under the mouse, and the app receives the WM_MouseMove due to win under mouse changed

Juha Manninen

2014-09-23 21:15

developer   ~0077567

I cannot reproduce.
Martin, I think was fixed with my hint window fixes and refactoring.
Please reopen if you still can reproduce.

Issue History

Date Modified Username Field Change
2013-05-25 16:46 Martin Friebe New Issue
2013-06-23 11:38 Paul Ishenin Note Added: 0068453
2013-06-23 11:38 Paul Ishenin Assigned To => Martin Friebe
2013-06-23 11:38 Paul Ishenin Status new => feedback
2013-06-26 11:18 Martin Friebe Note Added: 0068546
2013-06-26 11:18 Martin Friebe Status feedback => assigned
2013-06-26 11:35 Martin Friebe Note Added: 0068547
2013-06-26 11:35 Martin Friebe Assigned To Martin Friebe => Paul Ishenin
2013-06-27 21:05 Martin Friebe Note Added: 0068613
2014-09-23 21:11 Juha Manninen Relationship added related to 0020185
2014-09-23 21:14 Juha Manninen Assigned To Paul Ishenin => Juha Manninen
2014-09-23 21:15 Juha Manninen Note Added: 0077567
2014-09-23 21:15 Juha Manninen Status assigned => resolved
2014-09-23 21:15 Juha Manninen Resolution open => fixed
2019-04-22 19:33 Martin Friebe Status resolved => closed