View Issue Details

IDProjectCategoryView StatusLast Update
0024568LazarusIDEpublic2017-06-06 17:16
ReporterAvishaiAssigned ToMichl 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version1.1 (SVN)Product Build41582 
Target Version1.8Fixed in Version1.9 (SVN) 
Summary0024568: IDE Crashes after changing settings in ChildSizing.
DescriptionAfter changing settings of ChildSizing.Layout = cclTopToBottomThenLeftToRight in the Property Editor, almost any other changes, like changing BiDiMode, will generate an "Access Violation" and the IDE will crash. I have not had this problem before.
Steps To Reproduce1. Add 12 TLabels to a TPanel
2. set the TPanel ChildSizing to
    ControlsPerLine = 6
    EnlargeHorizontal = crsHomogenousChildResize
    EnlargeVertical = crsHomogenousChildResize
    Layout = cclTopToBottomThenLeftToRight
    ShrinkHorizontal = crsHomogenousChildResize
    ShrinkVertical = crsHomogenousChildResize
3. Set TPanel.BiDiMode = bdRightToLeft
4. This will generate an 'Access Violation' dialog
5.Click 'OK'
6. Soon after that the IDE crashes.

Additional InformationIt seems to have a problem with
    procedure TAutoSizeBox.SetControl(AControl: TControl);
TagsNo tags attached.
Fixed in Revisionr55213
LazTarget1.8
WidgetsetWin32/Win64
Attached Files

Relationships

related to 0031966 closedMichl AV: Application.BidiMode bdRightToLeft and Panel1.ChildSizing.Layout cclTopToBottomThenLeftToRight 

Activities

Avishai

2013-06-08 13:14

reporter   ~0068126

I don't see a 'Severity' setting in BugTracker anymore. What happened???

Reinier Olislagers

2013-06-08 14:24

developer   ~0068130

It's been removed so only developers can set it. http://bugs.freepascal.org/view.php?id=24535
I suspect because many people set it to extremely high just because it was important to them but not to the general users of FPC/Lazarus.
Happy to discuss this further on the forum, I don't think the bugtracker is the place for this.

Michl

2017-06-04 18:18

developer   ~0100860

Fixed in trunk revision 55213. Please test and close if OK.

Issue History

Date Modified Username Field Change
2013-06-08 12:54 Avishai New Issue
2013-06-08 13:14 Avishai Note Added: 0068126
2013-06-08 14:24 Reinier Olislagers Note Added: 0068130
2013-07-15 20:54 Mattias Gaertner Assigned To => Mattias Gaertner
2013-07-15 20:54 Mattias Gaertner Status new => assigned
2017-06-04 18:17 Michl Relationship added related to 0031966
2017-06-04 18:18 Michl Fixed in Revision => r55213
2017-06-04 18:18 Michl LazTarget => 1.8
2017-06-04 18:18 Michl Note Added: 0100860
2017-06-04 18:18 Michl Status assigned => resolved
2017-06-04 18:18 Michl Fixed in Version => 1.9 (SVN)
2017-06-04 18:18 Michl Resolution open => fixed
2017-06-04 18:18 Michl Assigned To Mattias Gaertner => Michl
2017-06-04 18:18 Michl Target Version => 1.8