View Issue Details

IDProjectCategoryView StatusLast Update
0024639LazarusLCLpublic2020-12-05 14:33
ReporterAvishai Assigned ToBart Broersma  
PrioritynormalSeverityminorReproducibilityN/A
Status resolvedResolutionno change required 
Summary0024639: property TTabSheet.Color should be published.
Descriptionproperty TTabSheet.Color should be published.
TagsNo tags attached.
Fixed in Revision
LazTarget-
WidgetsetWin32/Win64
Attached Files

Activities

ocean

2013-12-04 10:11

reporter  

color.patch (365 bytes)   
Index: lcl/comctrls.pp
===================================================================
--- lcl/comctrls.pp	(revision 43511)
+++ lcl/comctrls.pp	(working copy)
@@ -503,6 +503,7 @@
     property BorderWidth;
     property BiDiMode;
     property Caption;
+    property Color;
     property ChildSizing;
     property ClientHeight;
     property ClientWidth;
color.patch (365 bytes)   

Bart Broersma

2013-12-04 13:32

developer   ~0071764

Why _should_ it be published?
Or is this a feature request?

Avishai

2013-12-04 14:20

reporter   ~0071765

Maybe it is a feature request. The reason that it should be published is so that it's children pick up Color in ParentColor. But I guess that means that ParentColor should be published as well.

Bart Broersma

2020-12-05 14:33

developer   ~0127359

The color of a TTabSheet is determined ny the theme engine.
So in a default (themed) application setting Color doesn't have any effect at all.
If we publish this property then we can expect lots of bugreports saying "it does not work".

Please close.

Issue History

Date Modified Username Field Change
2013-06-23 09:17 Avishai New Issue
2013-12-04 10:11 ocean File Added: color.patch
2013-12-04 13:32 Bart Broersma Note Added: 0071764
2013-12-04 14:20 Avishai Note Added: 0071765
2020-12-05 14:33 Bart Broersma Assigned To => Bart Broersma
2020-12-05 14:33 Bart Broersma Status new => resolved
2020-12-05 14:33 Bart Broersma Resolution open => no change required
2020-12-05 14:33 Bart Broersma LazTarget => -
2020-12-05 14:33 Bart Broersma Widgetset Win32/Win64 => Win32/Win64
2020-12-05 14:33 Bart Broersma Note Added: 0127359