View Issue Details

IDProjectCategoryView StatusLast Update
0024693LazarusWidgetsetpublic2013-07-16 09:54
ReporterÉderson Cássio Assigned ToJuha Manninen  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionduplicate 
PlatformLinuxOSFedora 
Product Version1.0.10 
Summary0024693: Accents in IDE and my apps
DescriptionAll these problems occur in Lazarus IDE and in the applications I made in it.
When I type accented letters in components like TEdit, it duplicates the letter: "éé", "áá", "ãã". It happens even in Object Inspector and Lazarus dialog boxes.

In SynEdit, the accents don't appear. Since I use an US-international keyboard layout, for Brazilian Portuguese language (pt-BR), I'm not able to type the single quote (') needed for strings in source editor, because the same key is used both for acute (á) and the quote (').

Searching the forums and this bugtracker, I could only discover that's a GTK2 issue. I considered to change to Qt, but the "libQt4Pas" binding has many and big dependencies I don't need now, like libQtWebkit or libQtNetworking. Maybe when I get more free time, I'll download them all, but I didn't want to have to distribute and install so many packages. The other widgetsets support isn't mature yet, even Lazarus compiles but doesn't work with all of them (at least at my PC). I

In Windows, the accents work fine.

PS.: sorry 'bout the outflow!
Steps To Reproduce1. Configure the system input language to pt-BR (Brazilian Portuguese) or any other that requires accents.
2. Type some accented letter.
TagsNo tags attached.
Fixed in Revision
LazTarget-
WidgetsetGTK 2
Attached Files

Relationships

duplicate of 0024750 feedbackZeljan Rikalo Accents in GTK2 

Activities

Juha Manninen

2013-07-16 09:54

developer   ~0068879

Resolving as duplicate.

Issue History

Date Modified Username Field Change
2013-07-01 05:19 Éderson Cássio New Issue
2013-07-16 08:51 Juha Manninen Relationship added related to 0024750
2013-07-16 09:10 Juha Manninen Relationship replaced duplicate of 0024750
2013-07-16 09:54 Juha Manninen LazTarget => -
2013-07-16 09:54 Juha Manninen Note Added: 0068879
2013-07-16 09:54 Juha Manninen Status new => resolved
2013-07-16 09:54 Juha Manninen Resolution open => duplicate
2013-07-16 09:54 Juha Manninen Assigned To => Juha Manninen