View Issue Details

IDProjectCategoryView StatusLast Update
0024766LazarusIDEpublic2013-07-24 14:59
ReporterAnnaAssigned ToPaul Ishenin 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Platformx86OSWindows XP Pro SP3OS Version5.1.2600
Product Version1.1 (SVN)Product BuildLazarus-1.1-42134-fpc-2.7.1-2013 
Target VersionFixed in Version1.1 (SVN) 
Summary0024766: Form1 is always upper in z-order of Lazarus main window (window with run/stop buttons )
DescriptionSo if my project main window has Form.Left=0 and Form.Top=0, how can I run project?
TagsNo tags attached.
Fixed in Revisionr42171
LazTarget-
Widgetset
Attached Files

Relationships

duplicate of 0024763 resolvedPaul Ishenin Form Designer Always on Top if AnchorDocking installed 

Activities

Anna

2013-07-19 16:21

reporter   ~0068952

Last edited: 2013-07-19 16:23

View 2 revisions

http://img59.imageshack.us/img59/5880/1tw2.png

If I click for example a source editor window, it pushed itself to foreground . But ckicking a Main Lazarus window (with run/stop buttons) does not set itself upper Form1.

Juha Manninen

2013-07-19 16:47

developer   ~0068954

Anna, please check if r42113 caused the problem.

Anna

2013-07-19 21:02

reporter   ~0068961

Last edited: 2013-07-19 21:04

View 3 revisions

>> Anna, please check if r42113 caused the problem.

Revision 42113 (and previous) is deleted from ftp://freepascal.dfmk.hu/pub/lazarus/snapshots/

But in 42033 there was no such problem. (I'm using snapshots and not SVN becouse it needed third-party client and huge time to download and compile )

Juha Manninen

2013-07-20 00:40

developer   ~0068963

Last edited: 2013-07-20 00:45

View 2 revisions

Revision 42113 is not deleted from anywhere.
Yes you need SVN client obviously. Downloading latest diffs takes LESS time and bandwidth than snapshots.
Please ask on forum if you don't know these things.

Paul Ishenin

2013-07-22 04:20

manager   ~0068996

Seems that my experiment has failed :) I returned the behavior back with r42171. So please close this issue.

Anna

2013-07-24 14:59

reporter   ~0069071

Thank you very much.

Issue History

Date Modified Username Field Change
2013-07-19 16:19 Anna New Issue
2013-07-19 16:21 Anna Note Added: 0068952
2013-07-19 16:23 Anna Note Edited: 0068952 View Revisions
2013-07-19 16:46 Juha Manninen Relationship added duplicate of 0024763
2013-07-19 16:47 Juha Manninen LazTarget => -
2013-07-19 16:47 Juha Manninen Note Added: 0068954
2013-07-19 16:47 Juha Manninen Assigned To => Juha Manninen
2013-07-19 16:47 Juha Manninen Status new => feedback
2013-07-19 21:02 Anna Note Added: 0068961
2013-07-19 21:02 Anna Status feedback => assigned
2013-07-19 21:03 Anna Note Edited: 0068961 View Revisions
2013-07-19 21:04 Anna Note Edited: 0068961 View Revisions
2013-07-20 00:40 Juha Manninen Note Added: 0068963
2013-07-20 00:40 Juha Manninen Assigned To Juha Manninen => Paul Ishenin
2013-07-20 00:45 Juha Manninen Note Edited: 0068963 View Revisions
2013-07-22 04:20 Paul Ishenin Fixed in Revision => r42171
2013-07-22 04:20 Paul Ishenin Note Added: 0068996
2013-07-22 04:20 Paul Ishenin Status assigned => resolved
2013-07-22 04:20 Paul Ishenin Fixed in Version => 1.1 (SVN)
2013-07-22 04:20 Paul Ishenin Resolution open => fixed
2013-07-24 14:59 Anna Note Added: 0069071
2013-07-24 14:59 Anna Status resolved => closed