View Issue Details

IDProjectCategoryView StatusLast Update
0024777LazarusIDEpublic2013-07-24 23:46
ReporterAnnaAssigned ToJuha Manninen 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionunable to reproduce 
PlatformWindows XP Pro SP3 RussianOSWindows XP Pro SP3 RussianOS Version5.1.2600
Product Version1.1 (SVN)Product Build42191 
Target VersionFixed in Version 
Summary0024777: Bug # 17626 comes back (Fresh Lazarus installation fails to create events (e.g. OnClick))
DescriptionLazarus cannot create OnClick event.
Steps To ReproducePut Button1 on a Form1.
Double-click Button1 or click a DotDotDot-button in "Object Inspector - Events Tab".
TagsNo tags attached.
Fixed in Revision
LazTarget-
Widgetset
Attached Files

Relationships

related to 0017626 closedMattias Gaertner [regression] Fresh Lazarus installation fails to create events (e.g. OnClick) 

Activities

Anna

2013-07-24 04:39

reporter  

doubleclick_.PNG (85,716 bytes)
doubleclick_.PNG (85,716 bytes)

Anna

2013-07-24 04:59

reporter  

DotDotDot_Click.PNG (84,217 bytes)
DotDotDot_Click.PNG (84,217 bytes)

Anna

2013-07-24 04:59

reporter  

OnClick2_lrs_resources.zip (17,771 bytes)

Anna

2013-07-24 05:02

reporter   ~0069053

I have added a project also. This project causes same bug, but it appears many revisions back (not in 42191) .

Anna

2013-07-24 05:16

reporter   ~0069054

Last edited: 2013-07-24 05:39

View 4 revisions

Please stop developing and repair all bugs, because I cannot work normally.
First you make 24766. When you repair it , you add new bug 0024773(0024718). When you repair it , you add this bug... This is infinitely... So I cannot close previous issues , until you cure all bugs.

I'm still remain on slable 41033.

Cyrax

2013-07-24 05:55

reporter   ~0069056

Last edited: 2013-07-24 06:50

View 2 revisions

Can't reproduce this bug in r42191. Check that you have access to full FPC sources and path to it is correct in environment options.

Mattias Gaertner

2013-07-24 07:44

manager   ~0069058

What have you set in "Tools / Options / Environment / FPC Source directory"?

Anna

2013-07-24 10:11

reporter   ~0069061

Last edited: 2013-07-24 10:19

View 4 revisions

>>Can't reproduce this bug in r42191.

Yeap. I have downloaded ftp://freepascal.dfmk.hu/pub/lazarus/snapshots/Lazarus-1.1-42191-fpc-2.7.1-20130724-win32.exe and it has not this bug. Actually, I download first lazarus from thunk through fpcup... Lazarus, installed through fpcup, has empty field 'SVN revision' in Help > Abuot Lazarus. But fpcup inform me in sniffer ( http://svn.freepascal.org/svn/lazarus/!svn/bln/42191 ) , that it download 42191. For the nth time I got added evidence that direct download from SVN is defective.


But bug in OnClick2_lrs_resources.zip is present.


>>What have you set in "Tools / Options / Environment / FPC Source directory"?
In Lazarus from ftp (Lazarus-1.1-42191-fpc-2.7.1-20130724-win32.exe)
$(LazarusDir)fpc\$(FPCVer)\source
http://img15.imageshack.us/img15/2896/ood0.png

To Lazarus from SVN i have no access because now I'm not at home... I can check this in the evening.

Juha Manninen

2013-07-24 10:50

developer   ~0069063

Resolving as "unable to reproduce".
Anna, this is clearly a configuration issue on your side.
You apparently have many versions of FPC + Lazarus installed. It is an advanced configuration even for experienced people, and you are not experienced.
Please verify on forum that a bug exists _always_ before opening a report.
There are helpful people as you have seen.
I can see you enjoy the attention you get when many people try to reproduce your "bugs" but this is a wrong place for it. You can get attention on forum, too.

Anna

2013-07-24 10:55

reporter   ~0069064

Last edited: 2013-07-24 15:17

View 2 revisions

2 Juha Manninen
Do you test attachment? I will record video then...
Please see bug demonstration : http://youtu.be/X3QCP4n0yQ0

Juha Manninen

2013-07-24 16:55

developer   ~0069077

Last edited: 2013-07-24 16:59

View 2 revisions

> Do you test attachment?

No, I don't need to because the problem is so obvious. Besides your example requires MS Windows and I will not boot Windows for this kind of reason.
The (partly visible) Messages window in your screenshot says "Error: unit not found: classes"
It is a common symptom when you have screwed up the configuration somehow. You have wrong FPC config file, wrong FPC source path in Lazarus, old LCL .ppu files or something similar.
Please ask question on forum about how to fix your system. Don't reopen this issue any more!

Your video only shows that you installed a snapshot. Snapshots are the biggest source of problems based on complaints on forum and on false bug reports.
Get rid of snapshots please and configure properly ONE version of Lazarus.

Anna

2013-07-24 18:40

reporter   ~0069084

Last edited: 2013-07-24 18:42

View 5 revisions

You are wrong , Juha Manninen . Before each new install I delete lazarus folder and config folder in Local Settings. So you consider me an idiot, but it is not truth.

>>Don't reopen this issue any more!

Funny.
Do you think all people around you are idiots?

Anton

2013-07-24 19:38

reporter   ~0069087

Tools -> Rescan FPC source directory

Juha Manninen

2013-07-24 23:41

developer   ~0069092

> So you consider me an idiot, but it is not truth.

I do not consider you as idiot but this problem is not a bug in Lazarus. It is a problem in your local system.
The solution may be as simple as a clean build of Lazarus or "Rescan FPC source directory" as Anton suggested, but this bug tracker is not the right place to discuss your local problems. The bug tracker is meant for bugs in Lazarus project only.

Bart Broersma

2013-07-24 23:46

developer   ~0069093

Closing.
Use forum or mailinglist to discuss further.
Do not re-open.

Issue History

Date Modified Username Field Change
2013-07-24 04:39 Anna New Issue
2013-07-24 04:39 Anna File Added: doubleclick_.PNG
2013-07-24 04:59 Anna File Added: DotDotDot_Click.PNG
2013-07-24 04:59 Anna File Added: OnClick2_lrs_resources.zip
2013-07-24 05:02 Anna Note Added: 0069053
2013-07-24 05:16 Anna Note Added: 0069054
2013-07-24 05:16 Anna Note Edited: 0069054 View Revisions
2013-07-24 05:17 Anna Note Edited: 0069054 View Revisions
2013-07-24 05:39 Anna Note Edited: 0069054 View Revisions
2013-07-24 05:55 Cyrax Note Added: 0069056
2013-07-24 06:50 Cyrax Note Edited: 0069056 View Revisions
2013-07-24 07:44 Mattias Gaertner Note Added: 0069058
2013-07-24 10:11 Anna Note Added: 0069061
2013-07-24 10:14 Anna Note Edited: 0069061 View Revisions
2013-07-24 10:14 Anna Note Edited: 0069061 View Revisions
2013-07-24 10:19 Anna Note Edited: 0069061 View Revisions
2013-07-24 10:34 Juha Manninen Relationship added related to 0017626
2013-07-24 10:50 Juha Manninen LazTarget => -
2013-07-24 10:50 Juha Manninen Note Added: 0069063
2013-07-24 10:50 Juha Manninen Status new => resolved
2013-07-24 10:50 Juha Manninen Resolution open => unable to reproduce
2013-07-24 10:50 Juha Manninen Assigned To => Juha Manninen
2013-07-24 10:55 Anna Note Added: 0069064
2013-07-24 14:11 Anna Status resolved => assigned
2013-07-24 14:11 Anna Resolution unable to reproduce => reopened
2013-07-24 15:17 Anna Note Edited: 0069064 View Revisions
2013-07-24 16:55 Juha Manninen Note Added: 0069077
2013-07-24 16:55 Juha Manninen Status assigned => resolved
2013-07-24 16:55 Juha Manninen Resolution reopened => unable to reproduce
2013-07-24 16:59 Juha Manninen Note Edited: 0069077 View Revisions
2013-07-24 18:40 Anna Note Added: 0069084
2013-07-24 18:40 Anna Note Edited: 0069084 View Revisions
2013-07-24 18:41 Anna Note Edited: 0069084 View Revisions
2013-07-24 18:42 Anna Note Edited: 0069084 View Revisions
2013-07-24 18:42 Anna Note Edited: 0069084 View Revisions
2013-07-24 19:38 Anton Note Added: 0069087
2013-07-24 23:41 Juha Manninen Note Added: 0069092
2013-07-24 23:46 Bart Broersma Note Added: 0069093
2013-07-24 23:46 Bart Broersma Status resolved => closed