View Issue Details

IDProjectCategoryView StatusLast Update
0024817LazarusLCLpublic2014-05-01 16:42
ReporterVojtech CihakAssigned ToBart Broersma 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Platformamd64OSLinuxOS VersionChakra 64-bit
Product Version1.1 (SVN)Product Build42089 
Target VersionFixed in Version1.2.4 
Summary0024817: TToolButton and acceleration keys
DescriptionI noticed that acceleration keys does not work with TToolButton. I tested and DialogChar is broadcast correctly. In TToolButton.DialogChar (toolbutton.inc) is line(934):

if IsAccel(Message.CharCode, Caption) and FToolBar.CanFocus then
...

but ToolBar.CanFocus is overridden method

function TToolBar.CanFocus: Boolean;
begin
  Result := False;
end;

so it never happen. It is strange since ToolButton is used exclusively with TToolBar.
I would like to ask someone to test in Delphi, then we can invite patch or remove TToolButton.DialogChar.
Steps To ReproduceRun demo. Alt+T does nothing.
Additional InformationLazarus 1.1 r42089M FPC 2.7.1 x86_64-linux-qt

Of some reason, my mail to mailing list failed, so I give it directly here.
TagsNo tags attached.
Fixed in Revisionr44871
LazTarget-
Widgetset
Attached Files

Activities

Vojtech Cihak

2013-08-02 18:09

reporter  

ToolButtonAccel.zip (5,889 bytes)

Bart Broersma

2014-05-01 16:22

developer   ~0074728

Please close if OK.

Vojtech Cihak

2014-05-01 16:42

reporter   ~0074729

I almost forgot this report. In the meantime I installed Delphi7 where accel. works.
I tested with r.44871. Works well. Thanks.

Issue History

Date Modified Username Field Change
2013-08-02 18:09 Vojtech Cihak New Issue
2013-08-02 18:09 Vojtech Cihak File Added: ToolButtonAccel.zip
2014-05-01 16:22 Bart Broersma Fixed in Revision => r44871
2014-05-01 16:22 Bart Broersma LazTarget => -
2014-05-01 16:22 Bart Broersma Note Added: 0074728
2014-05-01 16:22 Bart Broersma Status new => resolved
2014-05-01 16:22 Bart Broersma Fixed in Version => 1.2.4
2014-05-01 16:22 Bart Broersma Resolution open => fixed
2014-05-01 16:22 Bart Broersma Assigned To => Bart Broersma
2014-05-01 16:42 Vojtech Cihak Note Added: 0074729
2014-05-01 16:42 Vojtech Cihak Status resolved => closed