View Issue Details

IDProjectCategoryView StatusLast Update
0024893LazarusLCLpublic2013-09-25 20:54
ReporterStefanoAssigned ToJesus Reyes 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformGTK2OSLinuxOS VersionDebian Squeeze
Product Version1.0.10Product Build 
Target Version1.2.0Fixed in Version1.3 (SVN) 
Summary0024893: DBGrid: Uppercase doesn't work with first character on GTK2
DescriptionHello, if I use this code in the KeyPress event of a dbgrid in order to force always uppercase:

  if Ord(Key) in [97..122] then begin
    Key := Chr(Ord(Key)-32);
  end;

this doesn't work with the first character inserted in the cell from the user. The other characters are set ok to uppercase.

I think that this is due to the passage from the editstate of the cell of the grid.

On Win32 the problem doesn't occour.

Best regards,

Stefano

TagsNo tags attached.
Fixed in Revision42936
LazTarget1.2
WidgetsetGTK 2
Attached Files

Relationships

related to 0018280 closedZeljan Rikalo Key changed in TEdit.OnKeyPress ignored 

Activities

Stefano

2013-08-21 11:56

reporter   ~0069473

If the user press before Enter or F2 and after that insert data in the cell of the grid, the problem doesn't occour.

Issue History

Date Modified Username Field Change
2013-08-21 11:54 Stefano New Issue
2013-08-21 11:56 Stefano Note Added: 0069473
2013-09-22 07:01 Jesus Reyes Assigned To => Jesus Reyes
2013-09-22 07:01 Jesus Reyes Status new => assigned
2013-09-25 18:48 Jesus Reyes Relationship added related to 0018280
2013-09-25 20:54 Jesus Reyes Fixed in Revision => 42936
2013-09-25 20:54 Jesus Reyes LazTarget => 1.2
2013-09-25 20:54 Jesus Reyes Status assigned => resolved
2013-09-25 20:54 Jesus Reyes Fixed in Version => 1.3 (SVN)
2013-09-25 20:54 Jesus Reyes Resolution open => fixed
2013-09-25 20:54 Jesus Reyes Target Version => 1.2.0