View Issue Details

IDProjectCategoryView StatusLast Update
0024926LazarusIDEpublic2013-10-09 17:10
ReporterRobson Dantas Assigned ToJuha Manninen  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionwon't fix 
Platform32 bitsOSUbuntu Linux 
Product Version1.1 (SVN) 
Summary0024926: save button does not enable after ...
DescriptionLazarus 1.1 r42522M FPC 2.6.2 i386-linux-gtk 2

After entering a font color in ListBox, the save button does not change (in IDE Lazarus)
Steps To Reproduce1 ListBox in TForm;
In Object Inspector --> Font >> Color;
Change other color;

the save button does not change
TagsNo tags attached.
Fixed in Revision
LazTarget-
WidgetsetGTK 2
Attached Files

Relationships

related to 0022438 closedsamuel herzog Changes to field-properties do not influence the IDE Save-button. 

Activities

Bart Broersma

2013-08-30 19:08

developer   ~0069597

It works in Lazarus 1.1 r41901 FPC 2.6.2 i386-win32-win32/win64.

Juha Manninen

2013-08-30 23:17

developer   ~0069600

The project save button? It changes to enabled for me with GTK2 Linux.

Robson Dantas

2013-08-31 13:53

reporter   ~0069603

see: http://www.meulinux.com.br/buttonsave.avi

Juha Manninen

2013-08-31 14:15

developer   ~0069605

I see but it behaves differently for me, using GTK2 + Linux.
It may be a GTK2 version dependent issue or something. I use Linux Mint 14 + KDE.

Robson Dantas

2013-08-31 14:47

reporter   ~0069606

I use Linux Ubuntu 12.04

Juha Manninen

2013-08-31 20:52

developer   ~0069614

What says?: $ dpkg -s libgtk2.0-0|grep '^Version'
Do you have Unity desktop?

Zeljan explained that Ubuntu has hacked GTK2 so that 2 events of edit controls come in wrong order. It causes many problems and is quite impossible to fix in LCL.
It also breaks the filter edits in Lazarus IDE. Please try some IDE window which has a filter. Does the '(filter)' text remain when the filter edit gets focus?

We may have other reports caused by the same Ubuntu hack. I think they will have a "Won't fix" resolution.
The solution is to use a Linux distro without the hack, or wait for a fix in Ubuntu.

Robson Dantas

2013-09-01 01:19

reporter   ~0069621

Version: 2.24.10-0ubuntu6

"Do you have Unity desktop?" YES

"The solution is to use a Linux distro without the hack, or wait for a fix in Ubuntu"
Fine with me, so did not bother.

Juha Manninen

2013-09-01 09:02

developer   ~0069622

How do the filter edits in Lazarus IDE behave?

Robson Dantas

2013-09-01 20:22

reporter   ~0069645

work very well

Juha Manninen

2013-09-22 12:55

developer   ~0070246

I am planning to resolve this as "not fixable" unless you have ideas how to fix it.
Please report the problem to Ubuntu or Unity project.
As a workaround you can use a better Linux distro, anything but Ubuntu + Unity.

Robson Dantas

2013-09-26 23:51

reporter   ~0070365

ok, close topic, using Xubuntu now.

Juha Manninen

2013-10-09 17:10

developer   ~0070698

Resolving as "won't fix".

Issue History

Date Modified Username Field Change
2013-08-30 19:00 Robson Dantas New Issue
2013-08-30 19:08 Bart Broersma Note Added: 0069597
2013-08-30 23:17 Juha Manninen Note Added: 0069600
2013-08-31 13:53 Robson Dantas Note Added: 0069603
2013-08-31 14:15 Juha Manninen Note Added: 0069605
2013-08-31 14:47 Robson Dantas Note Added: 0069606
2013-08-31 20:52 Juha Manninen LazTarget => -
2013-08-31 20:52 Juha Manninen Note Added: 0069614
2013-08-31 20:52 Juha Manninen Assigned To => Juha Manninen
2013-08-31 20:52 Juha Manninen Status new => feedback
2013-09-01 01:19 Robson Dantas Note Added: 0069621
2013-09-01 01:19 Robson Dantas Status feedback => assigned
2013-09-01 09:02 Juha Manninen Note Added: 0069622
2013-09-01 20:22 Robson Dantas Note Added: 0069645
2013-09-22 12:45 Juha Manninen Relationship added has duplicate 0025068
2013-09-22 12:55 Juha Manninen Note Added: 0070246
2013-09-22 12:55 Juha Manninen Status assigned => feedback
2013-09-23 21:06 samuel herzog Relationship added related to 0022438
2013-09-26 23:51 Robson Dantas Note Added: 0070365
2013-09-26 23:51 Robson Dantas Status feedback => assigned
2013-10-09 17:10 Juha Manninen Relationship deleted has duplicate 0025068
2013-10-09 17:10 Juha Manninen Note Added: 0070698
2013-10-09 17:10 Juha Manninen Status assigned => resolved
2013-10-09 17:10 Juha Manninen Resolution open => won't fix