View Issue Details

IDProjectCategoryView StatusLast Update
0024935LazarusIDEpublic2020-07-21 09:02
ReporterBart Broersma Assigned ToMattias Gaertner  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Platformi386OSWindow 
Product Version1.1 (SVN) 
Summary0024935: IDE does not respect "Add close statement for Pascal blocks" under certain conditions
DescriptionI have "Add close statement for Pascal blocks" enabled.

Code fragment:

begin
  foo;
  try|

| represents cursor.
If I press Enter I expect to get

begin
  foo;
  try
    |
  finally
  end;

but instead the cursor just moves 1 line down.
Steps To ReproduceEmpty Lazarus project.
DoubleClick on Form1.
Inside procedure TForm1.FormCreate(Sender: TObject) try what I did above.
Additional InformationI removed my configdir and restarted Lazarus.
The problem is gone.

I do Options->Editor->Display->Markup and Matches and enable the option "Disable timer for markup current word" (because I find it annoying).
Problem is back again.
TagsNo tags attached.
Fixed in Revision42865
LazTarget-
Widgetset
Attached Files

Relationships

related to 0037395 new "Add close statement for Pascal blocks" option did not work 

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2013-09-01 17:51 Bart Broersma New Issue
2013-09-01 17:53 Bart Broersma Additional Information Updated View Revisions
2013-09-01 17:57 Mattias Gaertner Assigned To => Mattias Gaertner
2013-09-01 17:57 Mattias Gaertner Status new => acknowledged
2013-09-18 23:05 Mattias Gaertner Fixed in Revision => 42865
2013-09-18 23:05 Mattias Gaertner Status acknowledged => resolved
2013-09-18 23:05 Mattias Gaertner Resolution open => fixed
2013-09-22 14:48 Bart Broersma Status resolved => closed
2020-07-21 09:02 Juha Manninen Relationship added related to 0037395