View Issue Details

IDProjectCategoryView StatusLast Update
0024959LazarusPrinterpublic2014-01-02 10:47
ReporterPetr-KAssigned ToJesus Reyes 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version1.1 (SVN)Product Buildtrunk #42516 
Target Version1.2.0Fixed in Version1.3 (SVN) 
Summary0024959: PrintDialog does not set Copies and Colate properties
DescriptionIf I change Copies or Colate in dialog then after dlg.Execute properties dlg.Copies and dlg.Collate are not set.

The patch solves it.
TagsNo tags attached.
Fixed in Revision43164
LazTarget1.2
Widgetset
Attached Files
  • cupsprndialogs.patch (751 bytes)
    Index: unix/cupsprndialogs.inc
    ===================================================================
    --- unix/cupsprndialogs.inc	(revision 42516)
    +++ unix/cupsprndialogs.inc	(working copy)
    @@ -63,6 +63,7 @@
       Dlg.Options := Self.Options;
       Dlg.PrintRange := Self.PrintRange;
       Dlg.cbCollate.Checked := Self.Collate;
    +  Dlg.edCopies.Value := Self.Copies;
       if Title<>'' then
         Dlg.Caption := Title
       else
    @@ -85,6 +86,8 @@
           // modifying fields accordingly.
     
           self.PrintRange:=dlg.PrintRange;
    +      Self.Collate := Dlg.cbCollate.Checked;
    +      Self.Copies := Dlg.edCopies.Value;
     
           // Page range. This migth get really complex because it's free enty
           //             textbox. To fill FromPage and ToPage we will use some
    
    cupsprndialogs.patch (751 bytes)

Activities

Petr-K

2013-09-06 13:25

reporter  

cupsprndialogs.patch (751 bytes)
Index: unix/cupsprndialogs.inc
===================================================================
--- unix/cupsprndialogs.inc	(revision 42516)
+++ unix/cupsprndialogs.inc	(working copy)
@@ -63,6 +63,7 @@
   Dlg.Options := Self.Options;
   Dlg.PrintRange := Self.PrintRange;
   Dlg.cbCollate.Checked := Self.Collate;
+  Dlg.edCopies.Value := Self.Copies;
   if Title<>'' then
     Dlg.Caption := Title
   else
@@ -85,6 +86,8 @@
       // modifying fields accordingly.
 
       self.PrintRange:=dlg.PrintRange;
+      Self.Collate := Dlg.cbCollate.Checked;
+      Self.Copies := Dlg.edCopies.Value;
 
       // Page range. This migth get really complex because it's free enty
       //             textbox. To fill FromPage and ToPage we will use some
cupsprndialogs.patch (751 bytes)

Jesus Reyes

2013-10-07 20:39

developer   ~0070632

Applied, thanks.

Petr-K

2014-01-02 10:47

reporter   ~0072169

Works

Issue History

Date Modified Username Field Change
2013-09-06 13:25 Petr-K New Issue
2013-09-06 13:25 Petr-K File Added: cupsprndialogs.patch
2013-09-22 06:25 Jesus Reyes Assigned To => Jesus Reyes
2013-09-22 06:25 Jesus Reyes Status new => assigned
2013-10-07 20:39 Jesus Reyes Fixed in Revision => 43164
2013-10-07 20:39 Jesus Reyes LazTarget => 1.2
2013-10-07 20:39 Jesus Reyes Note Added: 0070632
2013-10-07 20:39 Jesus Reyes Status assigned => resolved
2013-10-07 20:39 Jesus Reyes Fixed in Version => 1.3 (SVN)
2013-10-07 20:39 Jesus Reyes Resolution open => fixed
2013-10-07 20:39 Jesus Reyes Target Version => 1.2.0
2014-01-02 10:47 Petr-K Note Added: 0072169
2014-01-02 10:47 Petr-K Status resolved => closed