View Issue Details

IDProjectCategoryView StatusLast Update
0024970LazarusLCLpublic2013-09-07 20:27
ReporterStephanoAssigned ToBart Broersma 
PrioritynormalSeverityminorReproducibilityN/A
Status closedResolutionfixed 
Product Version1.3 (SVN)Product Build 
Target VersionFixed in Version1.1 (SVN) 
Summary0024970: Make TCustomMaskEdit.GetSel and SetSel protected
DescriptionTCustomMaskEdit.GetSel and SetSel are private whereas they are protected in Delphi.

Patch is attached.
TagsNo tags attached.
Fixed in Revisionr42665
LazTarget-
Widgetset
Attached Files
  • TCustomMaskEdit_GetSel_SetSel_protected_patch.diff (928 bytes)
    Index: lcl/maskedit.pp
    ===================================================================
    --- lcl/maskedit.pp	(revision 42663)
    +++ lcl/maskedit.pp	(working copy)
    @@ -199,8 +199,6 @@
         procedure JumpToNextDot(Dot: Char);
         function  HasSelection: Boolean;
         function  HasExtSelection: Boolean;
    -    procedure GetSel(out _SelStart: Integer; out _SelStop: Integer);
    -    procedure SetSel(const _SelStart: Integer; _SelStop: Integer);
     
         Function  CharToMask(UCh : TUtf8Char) : tMaskedType;
         Function  MaskToChar(Value : tMaskedType) : Char;
    @@ -216,6 +214,9 @@
         procedure DeleteSelected;
         procedure DeleteChars(NextChar : Boolean);
       protected
    +    procedure GetSel(out _SelStart: Integer; out _SelStop: Integer);
    +    procedure SetSel(const _SelStart: Integer; _SelStop: Integer);
    +
         function DisableMask(const NewText: String): Boolean;
         function RestoreMask(const NewText: String): Boolean;
     
    

Activities

Stephano

2013-09-07 16:13

developer  

TCustomMaskEdit_GetSel_SetSel_protected_patch.diff (928 bytes)
Index: lcl/maskedit.pp
===================================================================
--- lcl/maskedit.pp	(revision 42663)
+++ lcl/maskedit.pp	(working copy)
@@ -199,8 +199,6 @@
     procedure JumpToNextDot(Dot: Char);
     function  HasSelection: Boolean;
     function  HasExtSelection: Boolean;
-    procedure GetSel(out _SelStart: Integer; out _SelStop: Integer);
-    procedure SetSel(const _SelStart: Integer; _SelStop: Integer);
 
     Function  CharToMask(UCh : TUtf8Char) : tMaskedType;
     Function  MaskToChar(Value : tMaskedType) : Char;
@@ -216,6 +214,9 @@
     procedure DeleteSelected;
     procedure DeleteChars(NextChar : Boolean);
   protected
+    procedure GetSel(out _SelStart: Integer; out _SelStop: Integer);
+    procedure SetSel(const _SelStart: Integer; _SelStop: Integer);
+
     function DisableMask(const NewText: String): Boolean;
     function RestoreMask(const NewText: String): Boolean;
 

Bart Broersma

2013-09-07 18:28

developer   ~0069784

Please close if OK.
@Juha: I "hijacked" this issue from you, since I more or less maintain maskedit unit, so no offense intended.

Issue History

Date Modified Username Field Change
2013-09-07 16:13 Stephano New Issue
2013-09-07 16:13 Stephano Status new => assigned
2013-09-07 16:13 Stephano Assigned To => Juha Manninen
2013-09-07 16:13 Stephano File Added: TCustomMaskEdit_GetSel_SetSel_protected_patch.diff
2013-09-07 18:18 Bart Broersma Assigned To Juha Manninen => Bart Broersma
2013-09-07 18:28 Bart Broersma Fixed in Revision => r42665
2013-09-07 18:28 Bart Broersma Note Added: 0069784
2013-09-07 18:28 Bart Broersma Status assigned => resolved
2013-09-07 18:28 Bart Broersma Fixed in Version => 1.1 (SVN)
2013-09-07 18:28 Bart Broersma Resolution open => fixed
2013-09-07 20:27 Stephano Status resolved => closed