View Issue Details

IDProjectCategoryView StatusLast Update
0024973LazarusWidgetsetpublic2020-01-25 23:28
ReporterrealXCV Assigned ToJuha Manninen  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
OSOS X 
Product Version1.1 (SVN) 
Summary0024973: Empty items in TListBox.
DescriptionWhen adding an item to a TListBox (through .Items.Add(...)), an empty item is visually added at the bottom of the list but not in the items themselves.

If you add an OnSelectionChangeEvent to the list and you click on one of these fake items, it will become visually selected but the itemindex will be set to -1.
Additional InformationIn the screenshot, I never added the item that is selected.
Tagspatch
Fixed in Revisionr46204, r44729
LazTarget-
WidgetsetCarbon
Attached Files

Activities

realXCV

2013-09-08 01:50

reporter  

buglistbox.png (18,534 bytes)   
buglistbox.png (18,534 bytes)   

Bart Broersma

2013-09-08 13:43

developer   ~0069813

Works as expected on Win32, so probably Widgetset problem.

Bart Broersma

2013-09-08 13:44

developer   ~0069814

Please attach a compilable example (sources only) demonstrating the problem.

realXCV

2013-09-08 22:40

reporter  

project.zip (130,424 bytes)

realXCV

2013-09-08 22:42

reporter   ~0069826

Example added.

realXCV

2013-09-17 02:21

reporter  

patchempty.diff (418 bytes)   
Index: carbonstrings.pp
===================================================================
--- carbonstrings.pp	(revision 42845)
+++ carbonstrings.pp	(working copy)
@@ -239,7 +239,7 @@
 begin
   inherited InsertItem(Index, S);
 
-  FOwner.InsertItem(Index);
+  //FOwner.InsertItem(Index); //Already called. Don't call it again.
 end;
 
 {------------------------------------------------------------------------------
patchempty.diff (418 bytes)   

realXCV

2013-09-17 02:22

reporter   ~0070123

Nice little patch added too.

Juha Manninen

2014-09-13 12:04

developer   ~0077181

I applied the patch without testing because it has been ignored for a year now.
Please test.

Felipe Monteiro de Carvalho

2014-10-31 16:05

developer   ~0078775

This patch completely breaks adding items to TListBox at run time for me. I will revert it.

Juha Manninen

2014-10-31 18:15

developer   ~0078788

Ok, sorry. I detach myself from this issue.

Anton

2014-11-01 09:43

reporter   ~0078793

Didn't 44729r fix the issue?

realXCV

2020-01-25 21:14

reporter   ~0120739

I think this can be closed.

Issue History

Date Modified Username Field Change
2013-09-08 01:50 realXCV New Issue
2013-09-08 01:50 realXCV File Added: buglistbox.png
2013-09-08 13:43 Bart Broersma Note Added: 0069813
2013-09-08 13:44 Bart Broersma LazTarget => -
2013-09-08 13:44 Bart Broersma Note Added: 0069814
2013-09-08 13:44 Bart Broersma Status new => feedback
2013-09-08 22:40 realXCV File Added: project.zip
2013-09-08 22:42 realXCV Note Added: 0069826
2013-09-08 22:42 realXCV Status feedback => new
2013-09-17 02:20 realXCV Tag Attached: patch
2013-09-17 02:21 realXCV File Added: patchempty.diff
2013-09-17 02:22 realXCV Note Added: 0070123
2014-09-13 12:04 Juha Manninen Fixed in Revision => r46204
2014-09-13 12:04 Juha Manninen Note Added: 0077181
2014-09-13 12:04 Juha Manninen Status new => resolved
2014-09-13 12:04 Juha Manninen Resolution open => fixed
2014-09-13 12:04 Juha Manninen Assigned To => Juha Manninen
2014-10-31 16:05 Felipe Monteiro de Carvalho Note Added: 0078775
2014-10-31 16:05 Felipe Monteiro de Carvalho Status resolved => acknowledged
2014-10-31 18:14 Juha Manninen Assigned To Juha Manninen =>
2014-10-31 18:15 Juha Manninen Note Added: 0078788
2014-11-01 09:43 Anton Note Added: 0078793
2014-12-11 20:38 Bart Broersma Category LCL => Widgetset
2020-01-15 16:38 Bart Broersma Status acknowledged => feedback
2020-01-25 21:14 realXCV Note Added: 0120739
2020-01-25 21:14 realXCV Status feedback => new
2020-01-25 23:28 Juha Manninen Assigned To => Juha Manninen
2020-01-25 23:28 Juha Manninen Status new => resolved
2020-01-25 23:28 Juha Manninen Fixed in Revision r46204 => r46204, r44729
2020-01-25 23:28 Juha Manninen Widgetset Carbon => Carbon