View Issue Details

IDProjectCategoryView StatusLast Update
0024999LazarusCompilerpublic2016-02-13 11:48
ReporterMichael LaessigAssigned ToMichael Van Canneyt 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionduplicate 
PlatformOSwindowsOS VersionXP, Win8
Product VersionProduct Build2.7.1 
Target VersionFixed in Version 
Summary0024999: Eventhandler Parameters Changed between Versions
DescriptionI have installed both Lazarus and fpc from svn. i have also installed the package
virtualtreeview-new from svn
my project was created using older versions of them all.

the project / packages etc. compiles fine but at runtime i got strange segfaults.

after some searching i found out that some Eventhandlers have more Parameters in the newest version compared to the older version.

should the compiler not give out an errormessage in this circumstance?
TagsNo tags attached.
Fixed in Revision
LazTarget-
Widgetset
Attached Files

Relationships

duplicate of 0023032 confirmed IDE does not warn if eventhandler has wrong signature 

Activities

Sven Barth

2013-09-11 14:34

manager   ~0069921

Are those event handlers set through the *.lfm or through code? If the latter then please provide an explicit example if the former then there is currently no checking done at runtime whether the parameters are compatible. It *might* be possible with recently added RTTI features to add a check for this, but I'm not entirely sure.

Regards,
Sven

Michael Laessig

2013-09-12 10:08

reporter   ~0069955

the Eventhandlers are set trough the *.lfm using (the older) lazarus IDE.

Sven Barth

2013-09-12 13:56

manager   ~0069970

Then there is currently nothing that can be done. Whether the RTTI could help here needs to be investigated.

Regards,
Sven

Issue History

Date Modified Username Field Change
2013-09-11 11:08 Michael Laessig New Issue
2013-09-11 14:34 Sven Barth Note Added: 0069921
2013-09-11 14:34 Sven Barth Status new => feedback
2013-09-12 10:08 Michael Laessig Note Added: 0069955
2013-09-12 10:08 Michael Laessig Status feedback => new
2013-09-12 13:56 Sven Barth Note Added: 0069970
2016-02-08 16:52 Bart Broersma Relationship added related to 0023032
2016-02-13 11:47 Michael Van Canneyt Relationship deleted related to 0023032
2016-02-13 11:47 Michael Van Canneyt Relationship added duplicate of 0023032
2016-02-13 11:48 Michael Van Canneyt Project FPC => Lazarus
2016-02-13 11:48 Michael Van Canneyt LazTarget => -
2016-02-13 11:48 Michael Van Canneyt Status new => resolved
2016-02-13 11:48 Michael Van Canneyt Resolution open => duplicate
2016-02-13 11:48 Michael Van Canneyt Assigned To => Michael Van Canneyt