View Issue Details

IDProjectCategoryView StatusLast Update
0025073LazarusIDEpublic2014-05-20 09:44
ReporterStephanoAssigned ToMartin Friebe 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Platformi386OSUbuntuOS Version
Product Version1.3 (SVN)Product Build 
Target Version1.4Fixed in Version1.3 (SVN) 
Summary0025073: Breakpoints cause Save toolbutton to become enabled on every run
Description- Create a new project
- Set a breakpoint
- Save the project
- Run
The save and saveall toolbuttons will become enabled, and IDE internals indicate:
Project.Modified
Project.SomethingModified Data

This happens on every run.
TagsNo tags attached.
Fixed in Revision42934, 42935
LazTarget1.4
Widgetset
Attached Files

Activities

Mattias Gaertner

2013-09-23 11:08

manager   ~0070270

This is done by ide/debugmanager.pas

procedure TManagedBreakPoints.Update(Item: TCollectionItem);
begin
  inherited Update(Item);
  if Project1 <> nil
  then Project1.Modified := True;
end;

Martin Friebe

2013-09-25 16:17

manager   ~0070318

Please test.

This needs to be tested carefully for a while, to be sure that it will not cause the opposite bug: A real change, that does NOT mark the project as modified.

Do not close, please leave in resolve state for now.

Stephano

2013-09-25 18:53

developer   ~0070324

Seems to be solved.

Won't close the issue now as per Martin's request.

Stephano

2014-02-25 12:03

developer   ~0073283

@Martin,

Shall I close this issue?

Stephano

2014-05-20 09:44

developer   ~0075127

Enough time has elapsed. Closing the issue.

Issue History

Date Modified Username Field Change
2013-09-22 23:41 Stephano New Issue
2013-09-22 23:41 Stephano Status new => assigned
2013-09-22 23:41 Stephano Assigned To => Martin Friebe
2013-09-23 11:08 Mattias Gaertner Note Added: 0070270
2013-09-25 15:52 Martin Friebe LazTarget - => 1.4
2013-09-25 15:52 Martin Friebe Target Version => 1.4
2013-09-25 16:17 Martin Friebe Fixed in Revision => 42934
2013-09-25 16:17 Martin Friebe Note Added: 0070318
2013-09-25 16:17 Martin Friebe Status assigned => resolved
2013-09-25 16:17 Martin Friebe Fixed in Version => 1.3 (SVN)
2013-09-25 16:17 Martin Friebe Resolution open => fixed
2013-09-25 16:51 Martin Friebe Fixed in Revision 42934 => 42934, 42935
2013-09-25 18:53 Stephano Note Added: 0070324
2014-02-25 12:03 Stephano Note Added: 0073283
2014-05-20 09:44 Stephano Note Added: 0075127
2014-05-20 09:44 Stephano Status resolved => closed