View Issue Details

IDProjectCategoryView StatusLast Update
0025151LazarusOtherpublic2014-03-17 00:08
ReporterAndrey Zubarev Assigned ToZeljan Rikalo  
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Platformx86_64OSkUbuntu 
Product Version1.1 (SVN) 
Summary0025151: Poor support ThemeServices.DrawElement in GTK2
DescriptionThemeServices.DrawElement not works with teComboBox. Test program here http://forum.lazarus.freepascal.org/index.php/topic,22265
TagsNo tags attached.
Fixed in Revision43156,43176
LazTarget-
WidgetsetGTK 2
Attached Files

Activities

Zeljan Rikalo

2013-10-07 14:09

developer   ~0070610

Please test and close if ok. Note that combobox drawer implementation is hack/workaround since gtk2 doesn't have separate gtk_paint_combobox(), so there's a chance of wrong drawing in some themes and rightToLeft layouts.

Andrey Zubarev

2013-10-08 08:37

reporter   ~0070646

Not exactly as I expected, this draw all combobox, but in windows under the same conditions button is drawn separate. I attach a screenshot what it looks like in the test program and UxExplore with windows. If this can not be realized, let them remain and close the issue

Andrey Zubarev

2013-10-08 08:38

reporter  

tccombo.PNG (269,696 bytes)

Zeljan Rikalo

2013-10-08 15:52

developer   ~0070661

Please test and close if ok.

Andrey Zubarev

2013-10-08 19:06

reporter   ~0070669

Thanks!

Issue History

Date Modified Username Field Change
2013-10-06 12:04 Andrey Zubarev New Issue
2013-10-07 14:09 Zeljan Rikalo Fixed in Revision => 43156
2013-10-07 14:09 Zeljan Rikalo LazTarget => -
2013-10-07 14:09 Zeljan Rikalo Note Added: 0070610
2013-10-07 14:09 Zeljan Rikalo Status new => resolved
2013-10-07 14:09 Zeljan Rikalo Resolution open => fixed
2013-10-07 14:09 Zeljan Rikalo Assigned To => Zeljan Rikalo
2013-10-08 08:37 Andrey Zubarev Note Added: 0070646
2013-10-08 08:37 Andrey Zubarev Status resolved => assigned
2013-10-08 08:37 Andrey Zubarev Resolution fixed => reopened
2013-10-08 08:38 Andrey Zubarev File Added: tccombo.PNG
2013-10-08 15:52 Zeljan Rikalo Fixed in Revision 43156 => 43156,43176
2013-10-08 15:52 Zeljan Rikalo Note Added: 0070661
2013-10-08 15:52 Zeljan Rikalo Status assigned => resolved
2013-10-08 15:52 Zeljan Rikalo Resolution reopened => fixed
2013-10-08 19:06 Andrey Zubarev Note Added: 0070669
2013-10-08 19:06 Andrey Zubarev Status resolved => closed
2014-03-17 00:08 Juha Manninen Relationship added related to 0025844
2014-03-17 00:34 Juha Manninen Relationship deleted related to 0025844