View Issue Details

IDProjectCategoryView StatusLast Update
0025225LazarusLCLpublic2014-10-20 02:53
ReporterJose Maria CamargoAssigned ToJesus Reyes 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformLinuxOSUbuntuOS Version10.04
Product VersionProduct Build1.0.12 
Target Version1.4Fixed in Version1.3 (SVN) 
Summary0025225: Problem (DBGrid x Option DefaulDrawing (True/False) x OnDrawColumnCell
Descriptionevent occurs in any situation and the unstructured
Steps To ReproduceExemple:
DefaultDrawing := True;

procedure TForm8.DBGrid1DrawColumnCell(Sender: TObject; const Rect: TRect;
  DataCol: Integer; Column: TColumn; State: TGridDrawState);
begin
  with DBGrid1 do
    begin
      if Odd( DataSource.DataSet.RecNo) then
        Canvas.Brush.Color := clSilver
      else
        Canvas.Brush.Color := clMoneyGreen;

      Canvas.FillRect(Rect);
      DefaultDrawColumnCell(Rect,DataCol,Column,State);
    end;

end;
TagsNo tags attached.
Fixed in Revision46408
LazTarget1.4
Widgetset
Attached Files

Activities

Bart Broersma

2013-10-23 17:57

developer   ~0070951

Please move to Lazarus.

Jesus Reyes

2014-10-20 02:53

developer   ~0078406

I assue the reporter intended to show that the example code didn't work. Currently it works (probably fixed in r46408)

Issue History

Date Modified Username Field Change
2013-10-23 14:26 Jose Maria Camargo New Issue
2013-10-23 17:57 Bart Broersma Note Added: 0070951
2013-10-23 19:24 Jonas Maebe Project FPC => Lazarus
2013-11-12 22:43 Jesus Reyes Assigned To => Jesus Reyes
2013-11-12 22:43 Jesus Reyes Status new => assigned
2014-10-20 02:53 Jesus Reyes Fixed in Revision => 46408
2014-10-20 02:53 Jesus Reyes LazTarget => 1.4
2014-10-20 02:53 Jesus Reyes Note Added: 0078406
2014-10-20 02:53 Jesus Reyes Status assigned => resolved
2014-10-20 02:53 Jesus Reyes Fixed in Version => 1.3 (SVN)
2014-10-20 02:53 Jesus Reyes Resolution open => fixed
2014-10-20 02:53 Jesus Reyes Target Version => 1.4