View Issue Details

IDProjectCategoryView StatusLast Update
0025245LazarusLCLpublic2015-04-03 13:13
ReporterAvishaiAssigned ToBart Broersma 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product VersionProduct Build 
Target VersionFixed in Version1.3 (SVN) 
Summary0025245: TTabControl.OnDrawTab causes Error: Duplicate identifier "Active"
DescriptionStart a new project.
Add a TTabControl.
Add OnDrawTab event code.
Try to compile.

Result = Error: Duplicate identifier "Active"
TagsNo tags attached.
Fixed in Revisionr43337
LazTarget-
WidgetsetWin32/Win64
Attached Files
  • comctrls.pp.patch (490 bytes)
    Index: lcl/comctrls.pp
    ===================================================================
    --- lcl/comctrls.pp	(revision 43331)
    +++ lcl/comctrls.pp	(working copy)
    @@ -350,7 +350,7 @@
       TNoteBookCapabilities = TCTabControlCapabilities deprecated;
     
       TDrawTabEvent = procedure(Control: TCustomTabControl; TabIndex: Integer;
    -    const Rect: TRect; Active: Boolean) of object;
    +    const Rect: TRect; AActive: Boolean) of object;
     
       TCustomTabControl = class(TWinControl)
       private
    
    comctrls.pp.patch (490 bytes)

Activities

Cyrax

2013-10-28 12:12

reporter  

comctrls.pp.patch (490 bytes)
Index: lcl/comctrls.pp
===================================================================
--- lcl/comctrls.pp	(revision 43331)
+++ lcl/comctrls.pp	(working copy)
@@ -350,7 +350,7 @@
   TNoteBookCapabilities = TCTabControlCapabilities deprecated;
 
   TDrawTabEvent = procedure(Control: TCustomTabControl; TabIndex: Integer;
-    const Rect: TRect; Active: Boolean) of object;
+    const Rect: TRect; AActive: Boolean) of object;
 
   TCustomTabControl = class(TWinControl)
   private
comctrls.pp.patch (490 bytes)

Cyrax

2013-10-28 12:12

reporter   ~0071010

Added patch which should fix this problem.

Bart Broersma

2013-10-28 21:49

developer   ~0071014

Please test and close if OK.

Cyrax

2013-10-28 21:56

reporter   ~0071015

ComCtrls: change signature of TDrawTabEvent to avoid compilation error due to duplicatie identifier.
Issue 0025245. Patch by Avishai.
---

Not to nitpick or anything, but was it my patch that fixed this bug? :)

Issue History

Date Modified Username Field Change
2013-10-28 09:07 Avishai New Issue
2013-10-28 12:12 Cyrax File Added: comctrls.pp.patch
2013-10-28 12:12 Cyrax Note Added: 0071010
2013-10-28 21:49 Bart Broersma Fixed in Revision => r43337
2013-10-28 21:49 Bart Broersma LazTarget => -
2013-10-28 21:49 Bart Broersma Note Added: 0071014
2013-10-28 21:49 Bart Broersma Status new => resolved
2013-10-28 21:49 Bart Broersma Fixed in Version => 1.3 (SVN)
2013-10-28 21:49 Bart Broersma Resolution open => fixed
2013-10-28 21:49 Bart Broersma Assigned To => Bart Broersma
2013-10-28 21:56 Cyrax Note Added: 0071015
2013-10-29 06:30 Avishai Status resolved => closed