View Issue Details

IDProjectCategoryView StatusLast Update
0025253LazarusLCLpublic2014-03-26 23:43
ReporterVojtech Cihak Assigned ToZeljan Rikalo  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Platformamd64OSLinux 
Product Version1.3 (SVN) 
Target Version1.2.0 
Summary0025253: Font Color of TSpeedBtn cannot be changed
DescriptionFont Color of TSpeedBtn cannot be changed.
I have similar problems with my own TGraphicControl/TCustomControl descendants.
Steps To ReproduceRun demo. Text on TSpeedBtn should be red.
Additional InformationQt 4.8.5
KDE 4.11.2
Lazarus 1.3 r43290M FPC 2.7.1 x86_64-linux-qt
TagsNo tags attached.
Fixed in Revision43385,43386,44094
LazTarget1.2
WidgetsetQT
Attached Files

Activities

Vojtech Cihak

2013-10-29 19:31

reporter  

FontColor.zip (5,618 bytes)

Zeljan Rikalo

2013-10-30 07:12

developer   ~0071033

IMO, it should not be changed. It's theme drawn control + theme drawn text.
What about other widgetsets ?

Vojtech Cihak

2013-10-30 13:35

reporter   ~0071041

It works on GTK2 (text is red).
I am sure it worked on Qt4 too, 1 - 2 months ago.

Zeljan Rikalo

2013-10-31 09:47

developer   ~0071060

Yes, because Theme.DrawText is implemented, and LCL calls that function.

Zeljan Rikalo

2013-11-07 08:15

developer   ~0071169

Please test and close if ok.

Zeljan Rikalo

2013-11-07 08:34

developer   ~0071171

Just for fix regression

Zeljan Rikalo

2013-11-07 08:34

developer   ~0071172

Fixed regression (must restore pen color after text drawing)

Zeljan Rikalo

2013-11-07 11:21

developer   ~0071179

another regression fixed with r43387

Vojtech Cihak

2013-11-07 11:38

reporter   ~0071180

Thanks, now works well for Font.Color and Font.Styles (bold etc.) but not for Font.Orientation.
I can attach modified demo in the afternoon.

Vojtech Cihak

2013-11-07 22:01

reporter   ~0071199

New demo is not needed. You can try to change Font.Orientation of TSpeedBtn in OI. It doesn't work now. I don't know which revision broke it, I tested r.42500 where it worked well yet.

Zeljan Rikalo

2013-11-13 15:53

developer   ~0071302

There's no need to search. It does not work since themed DrawText() is implemented.

Zeljan Rikalo

2014-02-16 12:12

developer   ~0073086

Text rotation is fixed. Pls. close if ok.

Vojtech Cihak

2014-03-26 23:43

reporter   ~0073997

Thanks. I close.

Issue History

Date Modified Username Field Change
2013-10-29 19:31 Vojtech Cihak New Issue
2013-10-29 19:31 Vojtech Cihak File Added: FontColor.zip
2013-10-30 07:12 Zeljan Rikalo LazTarget => -
2013-10-30 07:12 Zeljan Rikalo Note Added: 0071033
2013-10-30 07:12 Zeljan Rikalo Assigned To => Zeljan Rikalo
2013-10-30 07:12 Zeljan Rikalo Status new => feedback
2013-10-30 07:13 Zeljan Rikalo Status feedback => assigned
2013-10-30 13:35 Vojtech Cihak Note Added: 0071041
2013-10-31 09:47 Zeljan Rikalo Note Added: 0071060
2013-11-07 08:15 Zeljan Rikalo Fixed in Revision => 43385
2013-11-07 08:15 Zeljan Rikalo Note Added: 0071169
2013-11-07 08:15 Zeljan Rikalo Status assigned => resolved
2013-11-07 08:15 Zeljan Rikalo Resolution open => fixed
2013-11-07 08:34 Zeljan Rikalo Note Added: 0071171
2013-11-07 08:34 Zeljan Rikalo Status resolved => assigned
2013-11-07 08:34 Zeljan Rikalo Resolution fixed => reopened
2013-11-07 08:34 Zeljan Rikalo Fixed in Revision 43385 => 43385,43386
2013-11-07 08:34 Zeljan Rikalo Note Added: 0071172
2013-11-07 08:34 Zeljan Rikalo Status assigned => resolved
2013-11-07 08:34 Zeljan Rikalo Resolution reopened => fixed
2013-11-07 11:21 Zeljan Rikalo Note Added: 0071179
2013-11-07 11:38 Vojtech Cihak Note Added: 0071180
2013-11-07 22:01 Vojtech Cihak Note Added: 0071199
2013-11-07 22:01 Vojtech Cihak Status resolved => assigned
2013-11-07 22:01 Vojtech Cihak Resolution fixed => reopened
2013-11-13 15:53 Zeljan Rikalo Note Added: 0071302
2014-02-15 20:56 Martin Friebe LazTarget - => 1.2
2014-02-15 20:56 Martin Friebe Target Version => 1.2.0
2014-02-16 12:12 Zeljan Rikalo Fixed in Revision 43385,43386 => 43385,43386,44094
2014-02-16 12:12 Zeljan Rikalo Note Added: 0073086
2014-02-16 12:12 Zeljan Rikalo Status assigned => resolved
2014-02-16 12:12 Zeljan Rikalo Resolution reopened => fixed
2014-03-26 23:43 Vojtech Cihak Note Added: 0073997
2014-03-26 23:43 Vojtech Cihak Status resolved => closed