View Issue Details

IDProjectCategoryView StatusLast Update
0025297FPCPackagespublic2019-09-20 15:39
ReportercsenkiAssigned ToMarco van de Voort 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionunable to reproduce 
Platformx86_64OSlinuxOS Versiongentto
Product Version2.6.2Product Build 
Target VersionFixed in Version 
Summary0025297: iconvert null ponint error
DescriptionIn the result string I get 0 charachters. With fpc 2.6.2, got wrong result, with fpc 2.4.0 got good result.
Steps To ReproduceThe result view in binary mode !
TagsNo tags attached.
Fixed in Revision
FPCOldBugId
FPCTarget-
Attached Files
  • iconvtest.pas (312 bytes)
    program iconvtest;
    uses sysutils,iconvenc;
    var src,tmp:ansistring;
    res:byte;
    
    Begin
    src:='S';
    tmp:='';
    res:=iconvert(src,tmp,'latin2','utf8');
    If ( res<>0 ) Then Begin
    	writeln('ERROR code:',res);
    	halt(1);
    End;
    writeln('src:',src,'|');
    writeln('res:',tmp,'|');
    writeln('len',length(tmp));
    End.
    
    iconvtest.pas (312 bytes)

Relationships

related to 0020531 new Package iconvenc fixed and tested for i386-win32 target 

Activities

csenki

2013-11-08 22:43

reporter  

iconvtest.pas (312 bytes)
program iconvtest;
uses sysutils,iconvenc;
var src,tmp:ansistring;
res:byte;

Begin
src:='S';
tmp:='';
res:=iconvert(src,tmp,'latin2','utf8');
If ( res<>0 ) Then Begin
	writeln('ERROR code:',res);
	halt(1);
End;
writeln('src:',src,'|');
writeln('res:',tmp,'|');
writeln('len',length(tmp));
End.
iconvtest.pas (312 bytes)

Jonas Maebe

2013-11-09 14:20

manager   ~0071225

Maybe some of the alleged fixes from 0020531 are relevant

Marco van de Voort

2013-11-10 14:01

manager   ~0071245

No that would leave excess characters.

Must test on a 64-bit system. (32-bit works fine, I checked)

Could also be simply Gentoo that is known to have new libs early.

Bugreporter, are both your 2.4.0 and 2.6.2 fixes with 64-bit?

Marco van de Voort

2013-12-06 18:36

manager   ~0071791

See last comment.

Marco van de Voort

2018-03-01 12:40

manager   ~0106792

restested on Debian Stable 64-bit, works fine. If you have more (recent) information, please reopen.

Issue History

Date Modified Username Field Change
2013-11-08 22:43 csenki New Issue
2013-11-08 22:43 csenki File Added: iconvtest.pas
2013-11-09 14:13 Marco van de Voort Assigned To => Marco van de Voort
2013-11-09 14:13 Marco van de Voort Status new => assigned
2013-11-09 14:20 Jonas Maebe Relationship added related to 0020531
2013-11-09 14:20 Jonas Maebe Note Added: 0071225
2013-11-10 14:01 Marco van de Voort Note Added: 0071245
2013-12-06 18:36 Marco van de Voort Note Added: 0071791
2013-12-06 18:36 Marco van de Voort Status assigned => feedback
2018-03-01 12:40 Marco van de Voort Note Added: 0106792
2018-03-01 12:40 Marco van de Voort Status feedback => resolved
2018-03-01 12:40 Marco van de Voort Resolution open => unable to reproduce
2019-09-20 15:39 Marco van de Voort Status resolved => closed
2019-09-20 15:39 Marco van de Voort FPCTarget => -