View Issue Details

IDProjectCategoryView StatusLast Update
0025310LazarusLazReportpublic2014-03-10 21:23
ReporterJean PatrickAssigned ToJesus Reyes 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionnot fixable 
Platformx86_64OSWindowsOS Version8
Product Version1.2.0RC1Product Build 
Target VersionFixed in Version 
Summary0025310: Error in file winprinters.inc, compiled on Win 64 bits
DescriptionError in file winprinters.inc, compiled on Win 64 bits, when the default printer is a network printer that is unavailable. In Windoiws 64 bits.
The error does not occur when compiled in 32 bits.
Steps To ReproduceHow to reproduce: set the Windows default printer to a network printer that is not available, insert into a form one frReport (LazReport) and compile in 64-bit Win. The error appears early on as shown in the images attached.
TagsNo tags attached.
Fixed in Revision
LazTarget-
WidgetsetWin32/Win64
Attached Files

Relationships

duplicate of 0023026 closedJesus Reyes Program crashes if printer units are added to project under windows 64bit 

Activities

Jean Patrick

2013-11-12 01:13

reporter  

images_error.zip (17,839 bytes)

Jean Patrick

2013-11-12 02:53

reporter   ~0071273

Just complementing, the error occurs with any printer offline. Even when the printer offline is not the default, but when it is selected in the preview of the LazReport, the error occurs.

Jean Patrick

2013-11-12 22:55

reporter   ~0071290

A call was made to test the Lazarus version 1.2 RC1.
There was duplication in Reporting the error because it was not fixed in the version that is to be stabilized.
The error is too serious to be left alone in the SVN version.

Jesus Reyes

2013-11-12 23:05

developer   ~0071291

Ok, no problem.

But this is an FPC 2.6.2 issue not a Lazarus issue. The problem does not occur if using FPC 2.7.1.

As Lazarus 1.2 binary will be distributed with FPC 2.6.2. This is something to think about.

Jean Patrick

2013-11-13 00:24

reporter   ~0071294

Got it. Really, this is a problem.

If there is no alternative, it only remains to close the case.

Jesus Reyes

2014-03-10 21:22

developer   ~0073617

Not fixable because FPC 2.6.2 problem, see inked report.

Issue History

Date Modified Username Field Change
2013-11-12 01:13 Jean Patrick New Issue
2013-11-12 01:13 Jean Patrick File Added: images_error.zip
2013-11-12 02:53 Jean Patrick Note Added: 0071273
2013-11-12 22:38 Jesus Reyes Relationship added duplicate of 0023026
2013-11-12 22:38 Jesus Reyes Assigned To => Jesus Reyes
2013-11-12 22:38 Jesus Reyes Status new => assigned
2013-11-12 22:39 Jesus Reyes LazTarget => -
2013-11-12 22:39 Jesus Reyes Status assigned => resolved
2013-11-12 22:39 Jesus Reyes Resolution open => duplicate
2013-11-12 22:55 Jean Patrick Note Added: 0071290
2013-11-12 22:55 Jean Patrick Status resolved => assigned
2013-11-12 22:55 Jean Patrick Resolution duplicate => reopened
2013-11-12 23:05 Jesus Reyes Note Added: 0071291
2013-11-13 00:24 Jean Patrick Note Added: 0071294
2014-03-10 21:22 Jesus Reyes Note Added: 0073617
2014-03-10 21:22 Jesus Reyes Status assigned => resolved
2014-03-10 21:22 Jesus Reyes Resolution reopened => not fixable
2014-03-10 21:23 Jesus Reyes Status resolved => closed