View Issue Details

IDProjectCategoryView StatusLast Update
0025400LazarusDatabase Componentspublic2013-12-09 18:53
ReporterBill Assigned ToLuiz Americo  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformWindowsOSXP Pro 
Summary0025400: TDBLookupCombobox ignores table sort
DescriptionWhen using a TDBLookupCombobox control, the displayed look up values are not sorted even though the lookup DB is sorted.
Steps To ReproduceIn the sample program:

1. At start, observe that the dblookupcombobox values are unsorted, and that they match the order of the DBGrid.
2. Press the button to sort the values by one field.
3. Observe that the dblookupcombobox values remain unsorted.
4. Press the button to sort the values by another field.
5. Observe that the dblookupcombobox values remain unsorted.

The dblookupcombobox drop down should follow the sort order of the underlying table.

Additional InformationPer the forum: " There is a missing call to a private procedure UpdateLookup in the TDBLookupComboBox. "

This was discussed here:

http://forum.lazarus.freepascal.org/index.php/topic,22865.0.html
TagsNo tags attached.
Fixed in Revision43512
LazTarget-
Widgetset
Attached Files

Activities

Bill

2013-12-05 21:57

reporter  

dblookupcombosort.zip (129,380 bytes)

Reinier Olislagers

2013-12-05 23:40

developer   ~0071779

DBLookupCombobox is a Lazarus control. Suggest assigning this to the Lazarus project.

Bill

2013-12-06 04:13

reporter   ~0071780

Two other observations I have noticed that may or may not be related:

1. If the combobox Sorted property is set to TRUE (to force the combobox to display sorted values), control inserts the wrong data into Datafield. They are out of sync.

2. When selecting an item from the dropdown list, the first selection usually doesn't insert into the table, the control flashes, I usually have to try several times to get the data to insert

Luiz Americo

2013-12-07 11:45

developer   ~0071801

About the issues cited in the notes, please test with svn from trunk since similar problems where fixed recently

Bill

2013-12-09 18:53

reporter   ~0071840

I am new to this, can you provide some instructions on how to do this?

Issue History

Date Modified Username Field Change
2013-12-05 21:57 Bill New Issue
2013-12-05 21:57 Bill Status new => assigned
2013-12-05 21:57 Bill Assigned To => Joost van der Sluis
2013-12-05 21:57 Bill File Added: dblookupcombosort.zip
2013-12-05 23:40 Reinier Olislagers Note Added: 0071779
2013-12-06 02:58 Luiz Americo Project FPC => Lazarus
2013-12-06 02:58 Luiz Americo Assigned To Joost van der Sluis => Luiz Americo
2013-12-06 04:13 Bill Note Added: 0071780
2013-12-07 11:45 Luiz Americo Fixed in Revision => 43512
2013-12-07 11:45 Luiz Americo LazTarget => -
2013-12-07 11:45 Luiz Americo Note Added: 0071801
2013-12-07 11:45 Luiz Americo Status assigned => resolved
2013-12-07 11:45 Luiz Americo Resolution open => fixed
2013-12-09 18:53 Bill Note Added: 0071840