View Issue Details

IDProjectCategoryView StatusLast Update
0025411LazarusLCLpublic2013-12-10 23:14
ReporterLuigiAssigned ToBart Broersma 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product VersionProduct Build 
Target VersionFixed in Version1.2.0 
Summary0025411: MB_ICONASTERICK is wrong on LCLType, Right is MB_ICONASTERISK
DescriptionHallo,
  on file LCLType at line772, the const MB_ICONASTERICK is wrong. The correct one is: MB_ICONASTERISK.

Even at line 776.
TagsNo tags attached.
Fixed in Revisionr43532
LazTarget-
WidgetsetWin32/Win64
Attached Files

Activities

Bart Broersma

2013-12-08 20:15

developer   ~0071823

I can't find any other Lazarus file where this constant is used.
Existing programs might however stop compiling when we change it.
Leave the wrong spelling in there and deprecate it?

  MB_ICONASTERISK = $00000040;
  MB_ICONASTERICK = MB_ICONASTERISK; //old typo, remove in 1.4?

Paul Ishenin

2013-12-09 02:44

manager   ~0071828

Simple replace the old declaration with new. It will be not hard for developers to notice the change since it is in code.

Luigi

2013-12-09 08:59

reporter   ~0071831

Last edited: 2013-12-09 08:59

View 2 revisions

MB_ICONASTERISK:
- is used in MessageBox (windows) function for "An icon consisting of a lowercase letter i in a circle appears in the message box".
- also for compatibility with Delphi

Bart Broersma

2013-12-10 23:00

developer   ~0071864

Please close if OK.

Bart Broersma

2013-12-10 23:13

developer   ~0071865

Documented in http://wiki.lazarus.freepascal.org/Lazarus_1.2.0_release_notes#LCLType:_fixed_typo_in_constant_declaration

Issue History

Date Modified Username Field Change
2013-12-08 19:03 Luigi New Issue
2013-12-08 19:09 Jonas Maebe Project FPC => Lazarus
2013-12-08 20:15 Bart Broersma Note Added: 0071823
2013-12-09 02:44 Paul Ishenin Note Added: 0071828
2013-12-09 08:59 Luigi Note Added: 0071831
2013-12-09 08:59 Luigi Note Edited: 0071831 View Revisions
2013-12-10 23:00 Bart Broersma Fixed in Revision => r43532
2013-12-10 23:00 Bart Broersma LazTarget => -
2013-12-10 23:00 Bart Broersma Widgetset => Win32/Win64
2013-12-10 23:00 Bart Broersma Note Added: 0071864
2013-12-10 23:00 Bart Broersma Status new => resolved
2013-12-10 23:00 Bart Broersma Fixed in Version => 1.2.0
2013-12-10 23:00 Bart Broersma Resolution open => fixed
2013-12-10 23:00 Bart Broersma Assigned To => Bart Broersma
2013-12-10 23:13 Bart Broersma Note Added: 0071865