View Issue Details

IDProjectCategoryView StatusLast Update
0025412FPCFCLpublic2014-03-24 20:41
ReporterBenjamin SchwarzeAssigned ToMichael Van Canneyt 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformallOSallOS Versionall
Product VersionProduct Buildtrunk 
Target Version3.0.0Fixed in Version2.6.4 
Summary0025412: Wrong parsing in TCustomApplication.CheckOptions
DescriptionIf the options is as short option, line 498 in CustApp checks if the following ParamStr looks like another options. If not, it's assumed to be the value of the current option (HaveArg := true).
Imho thats wrong and has to be determined via the colon(s) because it makes it impossible to use a short option as flag followed by a non-option.

Example: test.exe -f foo bar
With CheckOptions('f', '') only "bar" will be available in "NonOpts" but "foo" is treated as value of "-f", ignoring that "f" in CheckOptions wasn't followed by one or two colons.
TagsNo tags attached.
Fixed in Revision26853
FPCOldBugId
FPCTarget
Attached Files

Activities

Michael Van Canneyt

2014-01-24 14:55

administrator   ~0072633

Fixed, thanks for reporting.

Jonas Maebe

2014-03-04 16:17

manager   ~0073418

Merged in spite of 2.8.0 target version

Issue History

Date Modified Username Field Change
2013-12-08 21:08 Benjamin Schwarze New Issue
2013-12-22 23:57 Jonas Maebe Assigned To => Michael Van Canneyt
2013-12-22 23:57 Jonas Maebe Status new => assigned
2014-01-24 14:55 Michael Van Canneyt Fixed in Revision => 26574
2014-01-24 14:55 Michael Van Canneyt Note Added: 0072633
2014-01-24 14:55 Michael Van Canneyt Status assigned => resolved
2014-01-24 14:55 Michael Van Canneyt Fixed in Version => 2.7.1
2014-01-24 14:55 Michael Van Canneyt Resolution open => fixed
2014-01-24 14:55 Michael Van Canneyt Target Version => 2.8.0
2014-03-04 16:17 Jonas Maebe Fixed in Revision 26574 => 26853
2014-03-04 16:17 Jonas Maebe Note Added: 0073418
2014-03-04 16:17 Jonas Maebe Fixed in Version 2.7.1 => 2.6.4