View Issue Details

IDProjectCategoryView StatusLast Update
0025430LazarusDatabasepublic2014-01-02 09:07
ReporterLacaKAssigned ToMaxim Ganetsky 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version1.0.15 (SVN)Product Build 
Target VersionFixed in Version1.4 
Summary0025430: Add MySQL 5.6 Connection component to sqlDB palette
DescriptionThere was implemented TMySQL56Connection in FPC fcl-db
To be visible to end-users we need add new component to Lazarus

We need new image: tmysql56connection.png to components/sqldb/design
and update components/sqldb/registersqldb.pas (Patch is trivial)
TagsNo tags attached.
Fixed in Revision43604
LazTarget-
Widgetset
Attached Files

Relationships

related to 0025471 closedMaxim Ganetsky Add support for MySQL5.6 connector starting from FPC 2.6.4 

Activities

Reinier Olislagers

2013-12-28 01:45

developer   ~0072070

FYI for the FPC_FULLVERSION test in the patch: FPC fixes_2_6 r26283 added support for mysql5.6 so FPC 2.6.4 will contain it.

Maxim Ganetsky

2013-12-28 14:01

developer   ~0072072

Last edited: 2013-12-28 14:01

View 2 revisions

It seems that at least r26197 was not merged from FPC trunk to fixes_2_6?

Maxim Ganetsky

2013-12-28 15:42

developer   ~0072077

Added. Please test. It is enabled for FPC 2.7.1 and later for now because of missing r26197 in fixes_2_6.

Reinier Olislagers

2013-12-28 16:04

developer   ~0072078

@Maxim: yes, seems you're right:
dir C:\Development\fpcfixes26\packages\fcl-db\src\sqldb\mysql\mysql56conn.pas
...
File Not Found

Added note on
http://wiki.lazarus.freepascal.org/Issues_2.6.4

Issue History

Date Modified Username Field Change
2013-12-17 07:50 LacaK New Issue
2013-12-28 01:45 Reinier Olislagers Note Added: 0072070
2013-12-28 13:04 Maxim Ganetsky Assigned To => Maxim Ganetsky
2013-12-28 13:04 Maxim Ganetsky Status new => assigned
2013-12-28 14:01 Maxim Ganetsky LazTarget => -
2013-12-28 14:01 Maxim Ganetsky Note Added: 0072072
2013-12-28 14:01 Maxim Ganetsky Status assigned => feedback
2013-12-28 14:01 Maxim Ganetsky Note Edited: 0072072 View Revisions
2013-12-28 15:42 Maxim Ganetsky Fixed in Revision => 43604
2013-12-28 15:42 Maxim Ganetsky Note Added: 0072077
2013-12-28 15:42 Maxim Ganetsky Status feedback => resolved
2013-12-28 15:42 Maxim Ganetsky Fixed in Version => 1.4
2013-12-28 15:42 Maxim Ganetsky Resolution open => fixed
2013-12-28 16:04 Reinier Olislagers Note Added: 0072078
2013-12-30 17:33 Reinier Olislagers Relationship added related to 0025471
2014-01-02 09:07 LacaK Status resolved => closed