View Issue Details

IDProjectCategoryView StatusLast Update
0025464FPCOtherpublic2014-01-18 23:58
ReporterMaxim GanetskyAssigned ToMarco van de Voort 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionunable to reproduce 
PlatformWin32OSWindowsOS VersionXP SP3
Product Version2.6.3Product Buildr26283 
Target VersionFixed in Version 
Summary0025464: [regression] Fastcgi and fcl-web package are installed to incorrect destination
DescriptionWhen using e.g. the following command for FPC installation:

make install PREFIX=i:\FPC\2.6.3\

Fastcgi and fcl-web packages will be installed to "i:\FPC\2.6.3 -ie". All other packages are installed correctly.

Seems to be caused by r18116 merged in r25399
TagsNo tags attached.
Fixed in Revision
FPCOldBugId
FPCTarget
Attached Files

Activities

Marco van de Voort

2014-01-18 19:44

manager   ~0072532

Last edited: 2014-01-18 19:45

View 2 revisions

Can't reproduce (win32->wince):

make[4]: Entering directory `c:/repo/fixes_2_6/packages/fcl-web'
c:/repo/fixes_2_6/compiler/ppc.exe fpmake.pp -n -Fuc:/repo/fixes_2_6/rtl/units/i386-win32 -Fuc:/repo/fixes_2_6/packages/hash -Fuc:/repo/fixes_2_6/packages/paszlib -Fuc:/repo/fixes_2_6/packages/fcl-process -Fuc:/repo/fixes_2_6/packages/fpmkunit/units_bs/i386-win32
.\fpmake.exe install --localunitdir=../.. --globalunitdir=.. --os=wince --cpu=arm -o -Twince -o -Parm -o -XParm-wince- -o -Xr -o -Ur -o -Xs -o -O2 -o -n -o -Fuc:/repo/fixes_2_6/rtl/units/arm-wince -o -Fuc:/repo/fixes_2_6/packages/hash/units/arm-wince -o -Fuc:/repo/fixes_2_6/packages/paszlib/units/arm-wince -o -Fuc:/repo/fixes_2_6/packages/fcl-process/units/arm-wince -o -Fuc:/repo/fixes_2_6/packages/fpmkunit/units/arm-wince -o -FE. -o -FUunits/arm-wince -o -gl -o -darm -o -dRELEASE --compiler=c:/repo/fixes_2_6/compiler/ppcrossarm.exe --prefix=c:\pp32_26 -ie
Installing package fcl-web
Installation package fcl-web for target arm-wince succeeded
make[4]: Leaving directory `c:/repo/fixes_2_6/packages/fcl-web'

My guess was/is the trailing backspace is interpreted by something in make (or some other make related tool) to escape the next space. I tried to reproduce that, but to no avail. (no quotes are added the cmdline was

--prefix=c:\pp32_26\ -ie

)

Since I can't reproduce it with my vanilla setup, I can only conclude that somehow make.exe (or the tools) other than from FPC 2.6.2 were used. (e.g. cygwin or mingw installs)

Could you try to reproduce with ONLY fpc\2.6.2\bin\i386-win32 and windows dirs in your path?

Maxim Ganetsky

2014-01-18 21:58

reporter   ~0072533

I can't reproduce this anymore too. It appears to be temporary glitch.

Feel free to resolve this bug.

Marco van de Voort

2014-01-18 23:40

manager   ~0072534

Closed as unreproducible. Thanks for the feedback

Issue History

Date Modified Username Field Change
2013-12-28 16:26 Maxim Ganetsky New Issue
2014-01-18 19:44 Marco van de Voort Note Added: 0072532
2014-01-18 19:44 Marco van de Voort Assigned To => Marco van de Voort
2014-01-18 19:44 Marco van de Voort Status new => feedback
2014-01-18 19:45 Marco van de Voort Note Edited: 0072532 View Revisions
2014-01-18 21:58 Maxim Ganetsky Note Added: 0072533
2014-01-18 21:58 Maxim Ganetsky Status feedback => assigned
2014-01-18 23:40 Marco van de Voort Note Added: 0072534
2014-01-18 23:40 Marco van de Voort Status assigned => resolved
2014-01-18 23:40 Marco van de Voort Resolution open => unable to reproduce
2014-01-18 23:58 Maxim Ganetsky Status resolved => closed