View Issue Details

IDProjectCategoryView StatusLast Update
0025566LazarusLCLpublic2014-01-23 23:17
ReporterMike SapsardAssigned ToMartin Friebe 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platformx86/64 x86/32OSWindows LinuxOS Version7, Mint 16
Product Version1.2.0RC2Product Build43696 
Target Version1.2.0Fixed in Version1.3 (SVN) 
Summary0025566: Tabbing in stringgrid does not work
DescriptionWhen in stringgrid, tabbing does not work correctly. Also when moving out of an ellipsis cell, tab jumps to the next component, and all cells ignore mouse clicks.
Steps To ReproduceRun the included examples/gridexamples/columneditors/stringgrideditor.

Click in each cell from left and make an entry. When the ellipsis column is clicked on and the calculator appears, enter any number and click on the tick. It is not possible to enter another cell. Tabbing cycles to the ellipsis button, to the editbox and back again.
Additional InformationThis also fails in 1.3.
Prior to 1.2RC1 it worked correctly.
TagsNo tags attached.
Fixed in Revision43777
LazTarget1.2
WidgetsetWin32/Win64, QT
Attached Files

Activities

Martin Friebe

2014-01-20 17:38

manager   ~0072569

Last edited: 2014-01-20 17:39

View 2 revisions

This seems to depend on "goTabs" in the property "Options"

If that changed compared to older Versions, then a compatibility documentation is needed

Martin Friebe

2014-01-20 21:15

manager   ~0072572

Temporary target 1.2 / depends on feedback

I can not reproduce your findings. I tested and compared 1.2RC2 and 1.0.15

The example ships only with the former, so I opened the example from the RC2 in both versions of Lazarus.

The option goTabs is not set. So using tab to navigate in the example is not intended, and in both cases tab leaves the grid. (enter and cursor keys navigate cells)

If I set goTabs, then it works and tab will navigate through the cells. It will also do so after using the ellipses. I could not find a difference between 1.0.15 and 1.2RC2


I did test on win32.

-----
Please confirm if the "goTabs" options changes the behaviour to what you expect.

-----
"Prior to 1.2RC1" Which version or revision do you refer too?

Also since RC2 according to my findings (which match your description, if you did not change goTabs) works correct, this would mean that a previous version worked wrong. Or that you tested an example from 1.1 and the example used to be differently configured.

Martin Friebe

2014-01-20 21:19

manager   ~0072573

Actually, with regards to the ellipses, there is an issue (imho wrong)

When the ellipses field is active the [...] button is shown. In that case tab cycles grid-edit / grid-button / outside-grid in a loop.
It should only do grid-edit / outside-grid in a loop.

But this is the same in 1.0.15 and 1.2RC2

Mike Sapsard

2014-01-21 10:52

reporter   ~0072584

The older versions (1.0.12) did work slightly differently. They allowed tabbing to the right wihtout setting gotabs. There are now many more properties exposed in laz 1.2.

Setting gotabs to true in the earlier versions appears to provide consistent behaviour with laz 1.2.

Should I change the option and resubmit the example for 1.2RC2?

Martin Friebe

2014-01-21 15:43

manager   ~0072590

No need to resubmit all.

I will set the option. (goTabs)
Any other change required?

I tried with 1.0.12, same as current. But never mind. Anyway, IMHO if any version did, then that was a bug.

I will extract the ellipsis issue to a new report, and then close this issue, is that ok?

Martin Friebe

2014-01-21 15:50

manager   ~0072591

Last edited: 2014-01-21 16:11

View 2 revisions

Done in revision 43777 / Marked for merge to 1.2

See 0025575 for the tab+ellipses issue

Mike Sapsard

2014-01-21 21:10

reporter   ~0072595

Thanks Martin. There were no other issues.

Issue History

Date Modified Username Field Change
2014-01-20 17:04 Mike Sapsard New Issue
2014-01-20 17:38 Martin Friebe Note Added: 0072569
2014-01-20 17:39 Martin Friebe Note Edited: 0072569 View Revisions
2014-01-20 21:15 Martin Friebe LazTarget => 1.2
2014-01-20 21:15 Martin Friebe Note Added: 0072572
2014-01-20 21:15 Martin Friebe Status new => feedback
2014-01-20 21:15 Martin Friebe Target Version => 1.2.0
2014-01-20 21:19 Martin Friebe Note Added: 0072573
2014-01-21 10:52 Mike Sapsard Note Added: 0072584
2014-01-21 10:52 Mike Sapsard Status feedback => new
2014-01-21 15:43 Martin Friebe Note Added: 0072590
2014-01-21 15:43 Martin Friebe Assigned To => Martin Friebe
2014-01-21 15:43 Martin Friebe Status new => feedback
2014-01-21 15:50 Martin Friebe Note Added: 0072591
2014-01-21 16:11 Martin Friebe Note Edited: 0072591 View Revisions
2014-01-21 21:10 Mike Sapsard Note Added: 0072595
2014-01-21 21:10 Mike Sapsard Status feedback => assigned
2014-01-21 23:55 Martin Friebe Fixed in Revision => 43777
2014-01-21 23:55 Martin Friebe Status assigned => resolved
2014-01-21 23:55 Martin Friebe Fixed in Version => 1.3 (SVN)
2014-01-21 23:55 Martin Friebe Resolution open => fixed