View Issue Details

IDProjectCategoryView StatusLast Update
0025570LazarusIDEpublic2014-02-26 20:23
ReporterMaxim GanetskyAssigned ToMattias Gaertner 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformWin32OSWindowsOS VersionXP SP3
Product Version1.2.0RC2Product Build 
Target Version1.2.0Fixed in Version1.2.0 
Summary0025570: Object inspector stops working correctly when TChart series editor is opened
DescriptionObject inspector stops working correctly when TChart series editor is opened. See attached screenshot.

To reproduce:

1. Open attached project.
2. Select Chart1 on form.
3. In object inspector open editor of Series property.

This can be reproduced in Lazarus 1.2RC3 (r43759) and 1.3 (last tested with r43792), FPC 2.6.3 r26470 (latest to date).
TagsNo tags attached.
Fixed in Revision44226
LazTarget1.2
WidgetsetWin32/Win64
Attached Files

Activities

Maxim Ganetsky

2014-01-21 01:50

developer  

OI_TAChart.zip (2,228 bytes)

Maxim Ganetsky

2014-01-21 01:51

developer  

OI_mess.PNG (21,669 bytes)
OI_mess.PNG (21,669 bytes)

wp

2014-01-25 15:27

developer   ~0072659

Cannot reproduce - working fine here (Win 7/32: trunk r.43792 and 1.2RC2, Ubuntu: trunk r.43743)

Maxim Ganetsky

2014-01-25 16:22

developer   ~0072661

Which compiler version? It fails with FPC 2.6.3 for me.

wp

2014-01-25 16:33

developer   ~0072662

Win: fpc 2.6.2, Ubuntu: fpc 2.7.1. Tested another Win installation with fpc 2.7.1 and an older trunk (r. 42538). Working fine in all cases.

Maxim Ganetsky

2014-02-24 21:04

developer   ~0073262

It is definitely better now, but now when opening editor, tabs in OI become empty because it seems that previously selected item in components tree gets unselected. Is it possible to keep this selection?

Mattias Gaertner

2014-02-26 19:17

manager   ~0073337

The selection is cleared by the editor itself, not by the object inspector. See TComponentListEditorForm.SelectionChanged in unit TASubcomponentsEditor.
This has nothing to do with this bug.

Maxim Ganetsky

2014-02-26 20:23

developer   ~0073339

Ah, you are right. Thank you.

Issue History

Date Modified Username Field Change
2014-01-21 01:50 Maxim Ganetsky New Issue
2014-01-21 01:50 Maxim Ganetsky File Added: OI_TAChart.zip
2014-01-21 01:51 Maxim Ganetsky File Added: OI_mess.PNG
2014-01-21 01:52 Maxim Ganetsky Description Updated View Revisions
2014-01-25 13:35 Maxim Ganetsky LazTarget - => 1.2
2014-01-25 13:35 Maxim Ganetsky Target Version => 1.2.0
2014-01-25 15:27 wp Note Added: 0072659
2014-01-25 16:22 Maxim Ganetsky Note Added: 0072661
2014-01-25 16:33 wp Note Added: 0072662
2014-01-25 17:00 Maxim Ganetsky Description Updated View Revisions
2014-01-25 17:01 Maxim Ganetsky Description Updated View Revisions
2014-02-24 12:00 Mattias Gaertner Fixed in Revision => 44226
2014-02-24 12:00 Mattias Gaertner Status new => resolved
2014-02-24 12:00 Mattias Gaertner Resolution open => fixed
2014-02-24 12:00 Mattias Gaertner Assigned To => Mattias Gaertner
2014-02-24 21:04 Maxim Ganetsky Note Added: 0073262
2014-02-24 21:04 Maxim Ganetsky Status resolved => assigned
2014-02-24 21:04 Maxim Ganetsky Resolution fixed => reopened
2014-02-26 19:17 Mattias Gaertner Note Added: 0073337
2014-02-26 19:17 Mattias Gaertner Status assigned => resolved
2014-02-26 19:17 Mattias Gaertner Resolution reopened => fixed
2014-02-26 20:23 Maxim Ganetsky Note Added: 0073339
2014-02-26 20:23 Maxim Ganetsky Status resolved => closed
2014-02-26 20:23 Maxim Ganetsky Fixed in Version => 1.2.0