View Issue Details

IDProjectCategoryView StatusLast Update
0025695LazarusIDEpublic2014-03-17 21:14
ReporterJuha ManninenAssigned ToJuha Manninen 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version1.2.0RC2Product Build 
Target VersionFixed in Version 
Summary0025695: Standard installation of Lazarus on *nix systems cannot be rebuilt when "Clean all" is checked
DescriptionStandard installation goes to a write-protected directory on *nix systems.
If "Clean all" is checked in Configure Build Lazarus dialog, rebuilding gives an error:
---
This set of options to build Lazarus is not supported by this installation.
The directory "/usr/share/lazarus/1.2RC2/" is not writable.
See the Lazarus website for other ways to install Lazarus.
---

Suggested fix: hide "Clean all" when installation dir is write-protected.
Even better is to hide the whole "Clean up" groupbox as the "Clean common files" is very seldom needed. The automatic build logic works practically always in a standard installation.
This would also make the Configure Build Lazarus dialog less intimidating for new users.
TagsNo tags attached.
Fixed in Revisionmany revs
LazTarget-
Widgetset
Attached Files

Activities

Zeljan Rikalo

2014-02-08 12:22

developer   ~0072926

Well, you can hide "Clean All", but in that error message is missing "please disable Clean all and rebuild again".

Mattias Gaertner

2014-02-08 12:28

manager   ~0072928

Last edited: 2014-02-08 16:03

View 2 revisions

"Clean common files" is hardly used, because every one uses "Clean all". If "Clean all" is hidden, then "Clean common files" is the only option to clean up.

Mattias Gaertner

2014-02-08 12:41

manager   ~0072931

The "Clean common files" should be changed to not bark on write protected directories, so it cleans up the writable packages (i.e. installed third party packages).

Juha Manninen

2014-02-08 15:47

developer   ~0072945

Last edited: 2014-02-08 15:49

View 2 revisions

> The "Clean common files" should be changed to not bark on write protected directories

Mattias, "Clean common files" already works correctly. Only "Clean all" creates an error.
I just wanted to hide all the cleanup options because they are not useful for "normal" users running the standard installation under /usr/...

The whole cleanup is useful only after moving files or directories when developing Lazarus and its packages.
Even then "Clean common files" is not very useful. I noticed, if I have a build problem I must do "Clean all" always to solve it.

Anyway, the point is that when a user needs these cleanup options, he _always_ has the sources in a writable directory. They are not needed in a write-protected standard installation.

As I wrote, hiding the useless options would make the whole dialog less intimidating for new users.

Mattias Gaertner

2014-02-08 16:30

manager   ~0072948

I (still) agree that "Clean all" should definitely be hidden when the laz dir is not writable.
The option "Switch after ..." can also be hidden.

What is left is the "Clean common files".
If that is hidden, then the user has to clean up himself. I see pros and cons for that. Pro: it is used seldom and there is a trick to force a clean up: change the options. Con: A newbie does not know the trick.

Juha Manninen

2014-03-16 23:16

developer   ~0073752

Now a single checkbox for "Clean common files" is shown when installation dir is read-only. Radiobuttons are then hidden.

This change includes many refactoring commits + a change to the GUI. It is so invasive that it will not be backported to Lazarus 1.2.x.
After the refactorings Mattias found and fixed a bug in r44311 which may affect the rebuild problems in Linux that some people experience after standard Lazarus installation.

Issue History

Date Modified Username Field Change
2014-02-08 12:14 Juha Manninen New Issue
2014-02-08 12:22 Zeljan Rikalo Note Added: 0072926
2014-02-08 12:28 Mattias Gaertner Note Added: 0072928
2014-02-08 12:41 Mattias Gaertner Note Added: 0072931
2014-02-08 15:34 Juha Manninen Summary Standard installation of Lazarus on *nix systems cannot be rebuilt when "Clean all" if checked => Standard installation of Lazarus on *nix systems cannot be rebuilt when "Clean all" is checked
2014-02-08 15:47 Juha Manninen Note Added: 0072945
2014-02-08 15:49 Juha Manninen Note Edited: 0072945 View Revisions
2014-02-08 16:03 Mattias Gaertner Note Edited: 0072928 View Revisions
2014-02-08 16:30 Mattias Gaertner Note Added: 0072948
2014-02-17 08:23 Juha Manninen Assigned To => Juha Manninen
2014-02-17 08:23 Juha Manninen Status new => assigned
2014-03-16 23:16 Juha Manninen Fixed in Revision => many revs
2014-03-16 23:16 Juha Manninen Note Added: 0073752
2014-03-16 23:16 Juha Manninen Status assigned => resolved
2014-03-16 23:16 Juha Manninen Resolution open => fixed
2014-03-17 21:14 Juha Manninen Status resolved => closed