View Issue Details

IDProjectCategoryView StatusLast Update
0025708LazarusLCLpublic2014-02-14 14:46
ReporterSergey BulbaAssigned ToBart Broersma 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Platformwin32OSwindowsOS Versionxp,7
Product Version1.2.0RC2Product Build43696 
Target VersionFixed in Version1.2.0 
Summary0025708: TStringGrid: wrong keyboard shortcut for clipboard
DescriptionYou can copy selection of focused TStringGrid to clipboard with key combination like Ctrl+Alt+C
Steps To ReproduceIn new project place StringGrid1 to Form1, run application and press Ctrl+Alt+C, your previous Clipboard value will be erased.
Additional InformationIts new feature for me, that TStringGrid can copy its selection to clipboard via Ctrl+C, so (to avoid collision) I am forced to replace one of my TMainMenu item shortcut to Ctrl+Alt+C. To my surprise it did not solve the problem due the bug, for the moment I'd change it to Ctrl+Alt+F.

Anyway, its bug in my opinion.
TagsNo tags attached.
Fixed in Revisionr44056
LazTarget-
WidgetsetWin32/Win64
Attached Files

Activities

Bart Broersma

2014-02-12 14:46

developer   ~0073017

Please attached a compilable example (sources only) that demonstrates the issue.
ATM I cannot reproduce.
If I press Ctrl+Alt+C in the stringgrid, it wil insert a © (copyright sign) in the cell if I'm in editor mode.
If I'm not in editormode then Ctrl+Alt+C will not copy anything to the clipboard.
(Lazarus 1.3 r43974 FPC 2.6.4 i386-win32-win32/win64)

Sergey Bulba

2014-02-12 21:08

reporter  

tstringgriderror.zip (2,570 bytes)

Sergey Bulba

2014-02-12 21:12

reporter   ~0073025

See file. Try catch bug in non-editor mode: copy something to clipboard before running the example.

Bart Broersma

2014-02-13 18:55

developer   ~0073046

Last edited: 2014-02-13 19:08

View 2 revisions

Confirmed. Options must not contain goEdit for this bug to show.
Pressing Ctrl+Alt+C pushed the content of the selected cell on the clipboard, and appends a LineEnding to it.

Bart Broersma

2014-02-13 19:16

developer   ~0073047

Please close if OK.

Sergey Bulba

2014-02-14 14:46

reporter   ~0073056

Thanks, bug is fixed

Issue History

Date Modified Username Field Change
2014-02-12 03:58 Sergey Bulba New Issue
2014-02-12 14:46 Bart Broersma LazTarget => -
2014-02-12 14:46 Bart Broersma Note Added: 0073017
2014-02-12 14:46 Bart Broersma Status new => feedback
2014-02-12 21:08 Sergey Bulba File Added: tstringgriderror.zip
2014-02-12 21:12 Sergey Bulba Note Added: 0073025
2014-02-12 21:12 Sergey Bulba Status feedback => new
2014-02-13 18:55 Bart Broersma Note Added: 0073046
2014-02-13 18:55 Bart Broersma Status new => confirmed
2014-02-13 19:08 Bart Broersma Note Edited: 0073046 View Revisions
2014-02-13 19:16 Bart Broersma Fixed in Revision => r44056
2014-02-13 19:16 Bart Broersma Note Added: 0073047
2014-02-13 19:16 Bart Broersma Status confirmed => resolved
2014-02-13 19:16 Bart Broersma Fixed in Version => 1.2.0
2014-02-13 19:16 Bart Broersma Resolution open => fixed
2014-02-13 19:16 Bart Broersma Assigned To => Bart Broersma
2014-02-14 14:46 Sergey Bulba Note Added: 0073056
2014-02-14 14:46 Sergey Bulba Status resolved => closed