View Issue Details

IDProjectCategoryView StatusLast Update
0025746FPCRTLpublic2016-02-26 14:59
ReporterZoran VučenovićAssigned ToJonas Maebe 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionduplicate 
PlatformOSMac OS XOS Version
Product VersionProduct Build 
Target VersionFixed in Version 
Summary0025746: GetAppConfigDir function does not return appropriate path on Mac
DescriptionIt is reported in Lazarus forums that GetAppConfigDir function does not return the correct path on Mac.

Then, JWDietrich posts the code which solves this problem. Please see here: http://forum.lazarus.freepascal.org/index.php/topic,23541.msg140636.html#msg140636

I did not create a patch for two reasons - I do not use Mac and I do not have trunk version of FPC. However, I believe that JWDietrich's function, from the link I gave above, makes fixing this problem an easy task for fpc developers. That is why I'm creating this bug report.
TagsNo tags attached.
Fixed in Revision
FPCOldBugId
FPCTarget
Attached Files

Relationships

duplicate of 0020706 assignedJonas Maebe GetAppConfigDir delivers uncorrect path on Mac OS 

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2014-02-20 18:53 Zoran Vučenović New Issue
2014-02-20 18:58 Jonas Maebe Relationship added duplicate of 0020706
2014-02-20 18:58 Jonas Maebe Status new => resolved
2014-02-20 18:58 Jonas Maebe Resolution open => duplicate
2014-02-20 18:58 Jonas Maebe Assigned To => Jonas Maebe
2016-02-26 14:59 Zoran Vučenović Status resolved => closed