View Issue Details

IDProjectCategoryView StatusLast Update
0025809LazarusLCLpublic2016-12-25 15:14
ReporterSergey Bulba Assigned ToJuha Manninen  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Platformwin32OSwindows 
Product Version1.2.0RC2 
Summary0025809: TMainMenu: can launch disabled menu items via shortcuts
DescriptionIf you set MainMenu1.MenuItem1.Enabled:=False, however you can raise OnClick of submenu items via keyboard shortcuts.
Steps To ReproducePlace MainMenu1 on Form1, add MenuItem1 and create its child MenuItem2. Set MenuItem2.shortcut to some key, MenuItem2.OnClick to some test procedure, and than set MenuItem1.Enabled to False. Run application and press your key to ensure that disabled MenuItem2.OnClick is raised.
Additional InformationMoreover, you can raise several menu items onclick by only one shortcut pressing. If you set one shortcut to Ctrl+F6, and second to F6, and first is calling someform.ShowModal, after closing form second is raised (see example project).
TagsNo tags attached.
Fixed in Revision
LazTarget-
WidgetsetWin32/Win64
Attached Files

Relationships

duplicate of 0021720 resolvedZeljan Rikalo Shortcut Keys not disabled when parent menu is disabled 

Activities

Sergey Bulba

2014-03-03 05:54

reporter  

MainMenuBug.7z (2,226 bytes)

Juha Manninen

2014-10-02 14:22

developer   ~0077922

Last edited: 2014-10-02 14:22

View 2 revisions

Fixed together with the duplicate issue.

Sergey Bulba

2016-12-25 15:14

reporter   ~0097074

Thanks

Issue History

Date Modified Username Field Change
2014-03-03 05:54 Sergey Bulba New Issue
2014-03-03 05:54 Sergey Bulba File Added: MainMenuBug.7z
2014-03-03 13:21 Zeljan Rikalo Assigned To => Paul Ishenin
2014-03-03 13:21 Zeljan Rikalo Status new => assigned
2014-09-03 00:36 Juha Manninen Relationship added has duplicate 0021720
2014-09-03 00:36 Juha Manninen Relationship replaced duplicate of 0021720
2014-09-21 09:57 Juha Manninen Assigned To Paul Ishenin => Juha Manninen
2014-10-02 14:22 Juha Manninen LazTarget => -
2014-10-02 14:22 Juha Manninen Note Added: 0077922
2014-10-02 14:22 Juha Manninen Status assigned => resolved
2014-10-02 14:22 Juha Manninen Resolution open => fixed
2014-10-02 14:22 Juha Manninen Note Edited: 0077922 View Revisions
2016-12-25 15:14 Sergey Bulba Note Added: 0097074
2016-12-25 15:14 Sergey Bulba Status resolved => closed