View Issue Details

IDProjectCategoryView StatusLast Update
0025810LazarusLCLpublic2014-03-07 01:36
ReporterSergey BulbaAssigned ToJesus Reyes 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Platformwin32OSwindowsOS Versionxp,7 (32/64)
Product Version1.2.0RC2Product Build43696 
Target Version1.2.2Fixed in Version1.3 (SVN) 
Summary0025810: TStringGrid: wrong keyboard input processing
Description1. You cannot enter edit mode by pressing Enter key, if StringGrid1 is just appeared. After change selection (for example, by pressing Right-Left keys to reselect cell) you can.

2. You cannot move cursor in edited cell to desire position by Right or Left cursor key, because just entered cell is selected all, and next cell is selected instead of.
Steps To ReproducePlace StringGrid1 to Form1, set its option goEditing, fill some cells with values like "1234", "test", etc, run application and try do something from bugs description (without mouse, only keyboard!).
Additional InformationOr see my example in StringGridBugs.7z
TagsNo tags attached.
Fixed in Revision44361
LazTarget1.2.2
WidgetsetWin32/Win64
Attached Files

Activities

Sergey Bulba

2014-03-03 06:21

reporter  

StringGridBugs.7z (2,014 bytes)

Jesus Reyes

2014-03-06 05:37

developer   ~0073493

1. Fixed, please test.

2 is by design and is called FastEdit, if you want the behavior you describe set Grid.FastEditing := false

Sergey Bulba

2014-03-07 01:36

reporter   ~0073523

Thanks, works now!

Unfortunately, FastEditing property is not shown in Object Inspector, can set it only at runtime...

Issue History

Date Modified Username Field Change
2014-03-03 06:21 Sergey Bulba New Issue
2014-03-03 06:21 Sergey Bulba File Added: StringGridBugs.7z
2014-03-03 07:30 Zeljan Rikalo Assigned To => Jesus Reyes
2014-03-03 07:30 Zeljan Rikalo Status new => assigned
2014-03-06 05:37 Jesus Reyes Fixed in Revision => 44361
2014-03-06 05:37 Jesus Reyes LazTarget => 1.2.2
2014-03-06 05:37 Jesus Reyes Note Added: 0073493
2014-03-06 05:37 Jesus Reyes Status assigned => resolved
2014-03-06 05:37 Jesus Reyes Fixed in Version => 1.3 (SVN)
2014-03-06 05:37 Jesus Reyes Resolution open => fixed
2014-03-06 05:37 Jesus Reyes Target Version => 1.2.2
2014-03-07 01:36 Sergey Bulba Note Added: 0073523
2014-03-07 01:36 Sergey Bulba Status resolved => closed