View Issue Details

IDProjectCategoryView StatusLast Update
0025847LazarusLCLpublic2014-03-13 15:22
ReporterSergey BulbaAssigned ToJesus Reyes 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Platformwin32OSwindowsOS Version7,xp (32/64)
Product Version1.2.0RC2Product Build43696 
Target Version1.3 (SVN)Fixed in Version1.4 
Summary0025847: TStringGrid in edit cell mode: error sound when pressing Escape key on a form with TButton.Cancel=True
DescriptionPressing Escape key when editing cell will sound like "error key pressed" even if TButton.Cancel=True is placed to a form
Steps To ReproduceIn new project place StringGrid1 and then Button1 on Form1. Set StringGrid1.Options->goEditing to True and Button1.Cancel:=True.

Run application, type some text in any cell of StringGrid1 and press Escape key, error sound will be simultaneously with Button1.OnClick calling.
Additional InformationSee http://bugs.freepascal.org/view.php?id=25665 (same bug for TEdit) and attached file with example.
TagsNo tags attached.
Fixed in Revision44414
LazTarget1.4
WidgetsetWin32/Win64
Attached Files

Relationships

has duplicate 0025665 closedReinier Olislagers TEdit: error sound when pressing Escape key on a form with TButton.Cancel=True 

Activities

Sergey Bulba

2014-03-11 02:03

reporter  

StringGridEscapeSound.7z (2,038 bytes)

Jesus Reyes

2014-03-11 19:57

developer   ~0073636

Not a grids problem, and I was not able to reproduce the sound….

Sergey Bulba

2014-03-11 21:12

reporter   ~0073637

Just tested in 1.3 SVN (44376), sound is present. This is system sound, maybe it's turned off in your Windows scheme?

Jesus Reyes

2014-03-12 00:27

developer   ~0073639

It seems my sound scheme was modified as it appeared unnamed, but I tried the "default windows" ("Predeterminado de windows" in my language) scheme and still I cannot reproduce, I can ear other sounds though.

Can you isolate what entry in the sound scheme is the one being reproduced? this way I can check mine.

Sergey Bulba

2014-03-12 08:42

reporter  

Windows Ding.7z (80,618 bytes)

Sergey Bulba

2014-03-12 08:47

reporter   ~0073644

In my Windows 7 in default sound scheme it called simply "Standard sound" (I've just attached - Windows Ding.wav).

You can hear it in Windows in various situations, for example, in calc.exe pressing ln on zero, or 1/0= will sound with error message.

Jesus Reyes

2014-03-12 17:52

developer   ~0073649

I can reproduce in Windows 7, create a new project, drop a TEdit, run, edit and press ESC it will sound. I cannot reproduce under XP

Jesus Reyes

2014-03-13 01:07

developer   ~0073655

Please test.

Sergey Bulba

2014-03-13 13:34

reporter   ~0073670

Thanks! Error sound is disappeared in both TStringGrid and TEdit ;)

Issue History

Date Modified Username Field Change
2014-03-11 02:03 Sergey Bulba New Issue
2014-03-11 02:03 Sergey Bulba File Added: StringGridEscapeSound.7z
2014-03-11 08:46 Zeljan Rikalo Assigned To => Jesus Reyes
2014-03-11 08:46 Zeljan Rikalo Status new => assigned
2014-03-11 19:56 Jesus Reyes Assigned To Jesus Reyes =>
2014-03-11 19:57 Jesus Reyes Note Added: 0073636
2014-03-11 21:12 Sergey Bulba Note Added: 0073637
2014-03-12 00:27 Jesus Reyes Note Added: 0073639
2014-03-12 08:42 Sergey Bulba File Added: Windows Ding.7z
2014-03-12 08:47 Sergey Bulba Note Added: 0073644
2014-03-12 17:52 Jesus Reyes Note Added: 0073649
2014-03-13 01:06 Jesus Reyes Assigned To => Jesus Reyes
2014-03-13 01:07 Jesus Reyes Fixed in Revision => 44414
2014-03-13 01:07 Jesus Reyes LazTarget => 1.4
2014-03-13 01:07 Jesus Reyes Note Added: 0073655
2014-03-13 01:07 Jesus Reyes Status assigned => resolved
2014-03-13 01:07 Jesus Reyes Fixed in Version => 1.4
2014-03-13 01:07 Jesus Reyes Resolution open => fixed
2014-03-13 01:07 Jesus Reyes Target Version => 1.3 (SVN)
2014-03-13 13:34 Sergey Bulba Note Added: 0073670
2014-03-13 13:34 Sergey Bulba Status resolved => closed
2014-03-13 15:22 Reinier Olislagers Relationship added has duplicate 0025665