View Issue Details

IDProjectCategoryView StatusLast Update
0025878LazarusLCLpublic2014-04-21 20:36
ReporterZex AtillaAssigned ToJesus Reyes 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformOSOS VersionWin7 64
Product Version1.2.0Product Build 
Target Version1.2.4Fixed in Version1.3 (SVN) 
Summary0025878: ValueListEditor.Font refresh
DescriptionWhen changing parameters of the Font or TitleFont property, the control's appearance is not updated inside the Form Editor. You have to click on another control, then back, to refresh the new look.
TagsNo tags attached.
Fixed in Revision44775
LazTarget1.2.4
WidgetsetWin32/Win64
Attached Files

Relationships

duplicate of 0025877 resolvedJesus Reyes TStringGrid => TitleFont => Color ignored 

Activities

Bart Broersma

2014-03-18 18:23

developer   ~0073823

And this is not the case for TStringGrid?

Zex Atilla

2014-03-25 23:50

reporter   ~0073976

No, because TitleFont in TStringGrid does nothing. It's completely useless. At least on windows.

Bart Broersma

2014-04-04 13:00

developer   ~0074148

Let me refrase: the behaviour you observe is different than that from TStringGrid (when NOT using columns in that case)?
I ask this because there is no code in TValueListeditor that changes anything in the behaviour of font or titlefont.

Zex Atilla

2014-04-10 23:12

reporter   ~0074286

It's possible that the behavior is same in TStringGrid, but I can't test it without using Columns. There's no title text without Columns, so I can't test whether TitleFont change is applied right away. At runtime the TitleText without Columns does work, but I'm reporting a design-time bug.

Bart Broersma

2014-04-15 09:38

developer   ~0074409

TValueListEditor does NOT use columns at all, so I don't understand your answer.

Issue History

Date Modified Username Field Change
2014-03-17 22:51 Zex Atilla New Issue
2014-03-18 18:23 Bart Broersma Note Added: 0073823
2014-03-18 18:23 Bart Broersma LazTarget => -
2014-03-18 18:23 Bart Broersma Status new => feedback
2014-03-25 23:50 Zex Atilla Note Added: 0073976
2014-03-25 23:50 Zex Atilla Status feedback => new
2014-04-04 13:00 Bart Broersma Note Added: 0074148
2014-04-04 13:00 Bart Broersma Status new => feedback
2014-04-10 23:12 Zex Atilla Note Added: 0074286
2014-04-10 23:12 Zex Atilla Status feedback => new
2014-04-15 05:02 Jesus Reyes Assigned To => Jesus Reyes
2014-04-15 05:02 Jesus Reyes Status new => assigned
2014-04-15 09:38 Bart Broersma Note Added: 0074409
2014-04-21 17:39 Jesus Reyes Fixed in Revision => 44775
2014-04-21 17:39 Jesus Reyes LazTarget - => 1.2.2
2014-04-21 17:39 Jesus Reyes Status assigned => resolved
2014-04-21 17:39 Jesus Reyes Fixed in Version => 1.3 (SVN)
2014-04-21 17:39 Jesus Reyes Resolution open => fixed
2014-04-21 17:39 Jesus Reyes Target Version => 1.2.2
2014-04-21 17:42 Jesus Reyes Relationship added duplicate of 0025877
2014-04-21 20:36 Jesus Reyes LazTarget 1.2.2 => 1.2.4
2014-04-21 20:36 Jesus Reyes Target Version 1.2.2 => 1.2.4