View Issue Details

IDProjectCategoryView StatusLast Update
0025922LazarusWidgetsetpublic2014-03-28 17:56
ReporterVojtech Cihak Assigned ToZeljan Rikalo  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Platformamd64OSLinux 
Product Version1.3 (SVN) 
Summary0025922: Captions of disabled components are not grayed [Qt]
DescriptionCaptions of disabled components are not grayed when Font.Color <> clDefault.

It affects TButton or TCheckBox, but also TSpeedButton (seems ThemeServices.DrawText() cannot draw disabled theme).

Only TLabel seems to work.

Steps To ReproduceRun demo

or

Put TCheckBox, TButton, TSpeedButton, TRadioButton and form, change Enabled to False, Font.Color to clRed and Run project.

Additional InformationLazarus 1.3 r44526M FPC 2.7.1 x86_64-linux-qt
TagsNo tags attached.
Fixed in Revision44541
LazTarget-
WidgetsetQT
Attached Files

Activities

Vojtech Cihak

2014-03-27 00:14

reporter  

CaptionDisabled.zip (6,255 bytes)

Zeljan Rikalo

2014-03-27 11:49

developer   ~0074006

It is intended so.eg. I have application which is developed with kylix.
If Font.Color <> clWindowText (TPanel, Font.Color=clBlue) then disabled panel shows clBlue, but when Font.Color is clWindowText, then Font.Color = clGray.
Same applies especially for background colors.Again, eg. TPanel which is container for other controls and color is clNavy. When I disable such panel, all controls are disabled and that's fine, but I don't want that color of TPanel and other stuff becomes clGray, but color stays same, only input is not allowed.
Maybe I can set it up so Fonts respect palette disabled color , but for background it's pita since we don't have DisabledColor in LCL.

Vojtech Cihak

2014-03-27 13:06

reporter   ~0074015

IMO there's no need to do anything with background. Wine and Qt Designer seems to have the same color for enabled and disabled panel. (Although I don't know what is exact equivalent for our TPanel in Qt - if any, I tested QFrame and QWidget).

Zeljan Rikalo

2014-03-27 20:59

developer   ~0074028

It's QFrame.

Vojtech Cihak

2014-03-27 21:34

reporter   ~0074030

OK. I tried RadioButton and CheckBox with non-default text color on QFrame. They are always grayed when disabled. It was in Lazarus too, recently.

Zeljan Rikalo

2014-03-28 17:37

developer   ~0074041

Please test and close if ok.

Vojtech Cihak

2014-03-28 17:56

reporter   ~0074043

I tested with r.44541. Thank you.

Issue History

Date Modified Username Field Change
2014-03-27 00:14 Vojtech Cihak New Issue
2014-03-27 00:14 Vojtech Cihak File Added: CaptionDisabled.zip
2014-03-27 11:45 Zeljan Rikalo Assigned To => Zeljan Rikalo
2014-03-27 11:45 Zeljan Rikalo Status new => assigned
2014-03-27 11:49 Zeljan Rikalo LazTarget => -
2014-03-27 11:49 Zeljan Rikalo Note Added: 0074006
2014-03-27 11:49 Zeljan Rikalo Status assigned => feedback
2014-03-27 13:06 Vojtech Cihak Note Added: 0074015
2014-03-27 13:06 Vojtech Cihak Status feedback => assigned
2014-03-27 20:59 Zeljan Rikalo Note Added: 0074028
2014-03-27 21:34 Vojtech Cihak Note Added: 0074030
2014-03-28 17:37 Zeljan Rikalo Fixed in Revision => 44541
2014-03-28 17:37 Zeljan Rikalo Note Added: 0074041
2014-03-28 17:37 Zeljan Rikalo Status assigned => resolved
2014-03-28 17:37 Zeljan Rikalo Resolution open => fixed
2014-03-28 17:56 Vojtech Cihak Note Added: 0074043
2014-03-28 17:56 Vojtech Cihak Status resolved => closed