View Issue Details

IDProjectCategoryView StatusLast Update
0025937LazarusLCLpublic2014-04-03 20:58
Reportertintinux Assigned ToJesus Reyes  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionduplicate 
PlatformWindowsOSWindows 
Product Version1.2.0 
Target Version1.2.2Fixed in Version1.3 (SVN) 
Summary0025937: StringGrid : can't select 2nd cell with mouse when first one has a button (cbsEllipsis)
DescriptionWhen a StringGrid have a column with ButtonStyle = cbsEllipsis and this column is initially selected, it is no more possible to go to another column with the mouse.

This was not happening with 1.0.14 on Windows, and do not happen on both versions on Linux.

Steps To ReproduceDecompress and install the attached project and run.

Try to click the second cell : nothing happen, focus remain in 1st cell.

Goto the second cell with right arrow key : ok.

Then you can click to other columns.

TagsNo tags attached.
Fixed in Revision44415
LazTarget1.2.2
WidgetsetWin32/Win64
Attached Files

Relationships

duplicate of 0025824 closedJesus Reyes DBGrid Focus regression 

Activities

wp

2014-03-29 16:58

developer   ~0074062

Duplicate of 0025824 which is resolved. Please close.

tintinux

2014-03-30 11:17

reporter  

StringGrid2.zip (2,113 bytes)

tintinux

2014-03-30 11:20

reporter   ~0074075

I have uploaded another test program, StringGrid2.zip, because the first one had useless dependances.

Can't delete StringGrid.zip I uploaded, An administrator can delete it.

Reinier Olislagers

2014-03-30 11:56

developer   ~0074076

Deleted as per user request

tintinux

2014-04-01 09:06

reporter   ~0074111

The impact is not "minor".

We can't wait for release 1.4 to have this fixed, or this mean that we can't use 1.2 until 1.4 is released.

Please fix it in 1.2.2, and/or publish a patch for 1.2.0.

Issue History

Date Modified Username Field Change
2014-03-28 17:33 tintinux New Issue
2014-03-28 17:33 tintinux File Added: StringGrid.zip
2014-03-29 16:58 wp Note Added: 0074062
2014-03-30 11:17 tintinux File Added: StringGrid2.zip
2014-03-30 11:20 tintinux Note Added: 0074075
2014-03-30 11:56 Reinier Olislagers File Deleted: StringGrid.zip
2014-03-30 11:56 Reinier Olislagers Note Added: 0074076
2014-04-01 09:06 tintinux Note Added: 0074111
2014-04-03 16:30 Jesus Reyes Assigned To => Jesus Reyes
2014-04-03 16:30 Jesus Reyes Status new => assigned
2014-04-03 20:24 Jesus Reyes Relationship added duplicate of 0025824
2014-04-03 20:25 Jesus Reyes Fixed in Revision => 44415
2014-04-03 20:25 Jesus Reyes LazTarget => 1.4
2014-04-03 20:25 Jesus Reyes Status assigned => resolved
2014-04-03 20:25 Jesus Reyes Fixed in Version => 1.3 (SVN)
2014-04-03 20:25 Jesus Reyes Resolution open => duplicate
2014-04-03 20:25 Jesus Reyes Target Version => 1.4
2014-04-03 20:58 Martin Friebe LazTarget 1.4 => 1.2.2
2014-04-03 20:58 Martin Friebe Target Version 1.4 => 1.2.2
2014-04-03 20:58 Martin Friebe Description Updated View Revisions