View Issue Details

IDProjectCategoryView StatusLast Update
0025986LazarusDebuggerpublic2014-04-20 13:17
ReporterDenis VolodarskyAssigned ToJoost van der Sluis 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Platformx86OSWindowsOS Version7
Product VersionProduct Build 
Target VersionFixed in Version1.3 (SVN) 
Summary0025986: [FpDebug] Process not terminated from IDE
DescriptionWhen user closes process window it seems fine.

When Stop button pressed in IDE, it receives EXIT_PROCESS_DEBUG_EVENT and process it but in Windows it must also call ContinueDebugEvent to release/unmap process.
TagsNo tags attached.
Fixed in Revision44705
LazTarget-
WidgetsetWin32/Win64
Attached Files

Activities

Joost van der Sluis

2014-04-16 18:14

manager   ~0074427

It's nice to see that someone found this debugger on his own and tried to use it. Note however that it's under really heavy development, and has lots of issues.

I encourage everyone to try and test is, but I think it's not necessary to report all found bugs at this stage. simply because I will encounter them myself...

Otoh, if you also have the solution, like in this case, it could to beneficial report them. And if you want to help with the development, send me an email, so we won't do things double.

Denis Volodarsky

2014-04-20 13:17

reporter   ~0074470

I see. Thanks for working on pure debugger. I will test it, won't bother at early stage :)
btw I can't get your email, it shows Access Denied.

Issue History

Date Modified Username Field Change
2014-04-08 10:00 Denis Volodarsky New Issue
2014-04-08 10:00 Denis Volodarsky Status new => assigned
2014-04-08 10:00 Denis Volodarsky Assigned To => Martin Friebe
2014-04-08 14:10 Martin Friebe LazTarget => -
2014-04-08 14:10 Martin Friebe Assigned To Martin Friebe => Joost van der Sluis
2014-04-16 18:14 Joost van der Sluis Fixed in Revision => 44705
2014-04-16 18:14 Joost van der Sluis Note Added: 0074427
2014-04-16 18:14 Joost van der Sluis Status assigned => resolved
2014-04-16 18:14 Joost van der Sluis Fixed in Version => 1.3 (SVN)
2014-04-16 18:14 Joost van der Sluis Resolution open => fixed
2014-04-20 13:17 Denis Volodarsky Note Added: 0074470
2014-04-20 13:17 Denis Volodarsky Status resolved => closed