View Issue Details

IDProjectCategoryView StatusLast Update
0026018LazarusPackagespublic2016-06-29 03:05
ReporterAllan E. Registos Assigned ToZeljan Rikalo  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformLinuxOSUbuntu 
Product Version1.2.0 
Summary0026018: Always On Top (Linux) ZVDatetimeCtrls's Date Picker pop-up doesn't show
DescriptionIn linux, we have this privilege to keep a certain application window on top of any window by right-clicking the top bar and click 'Always On Top' from the context menu.

Using ZVDatetimeCtrls 1.4's control, the TZVDateTimePicker, the date picker popup no longer visible when we enable 'Always On Top' from the context menu. When the control is clicked with 'Always On Top' enabled, the popup is actually behind the application Window so it is no longer visible.

This might be an issue for some Linux users who accidentally or incidentally enabled the Always On Top feature on Linux and that they may stumble upon this bug.
Steps To Reproduce1. If there is no 'Date and Time Ctrls' then Install the ZVDateTimeCtrls1.4 package / then rebuild lazarus.
2. Restart Lazarus and create a New Application project
3. Find the 'Date and Time Ctrls' tab in the toolbar and click it
4. Click 'TZVDateTimePicker' and drop it on the form.
5. Run the project
6. Click the Date Picker control to test
7. Right click the top bar of your running project
8. From the context menu, click 'Always On Top'
9. Click the Date Picker again and the popup is no longer visible.
Additional InformationAttached gzip file is the test project for anyone to quickly reproduce the bug.
Tags"ZVDateTimeCtrls-1.4", "ZVDateTimePicker"
Fixed in Revision44723,44724,44731
LazTarget-
WidgetsetGTK 2, QT
Attached Files

Relationships

related to 0028863 closedZeljan Rikalo SetFocus have no effect after TCustomForm.Show 

Activities

Allan E. Registos

2014-04-14 10:39

reporter  

zvdt.tar.gz (1,582 bytes)

Zeljan Rikalo

2014-04-14 10:55

developer   ~0074385

Ok, this is problem on X11 only.We use TCustomForm fsStayOnTop as relevant stay on top information, but it isn't true since under X11 user can set "Always on top" and our form don't know about such change.

Zeljan Rikalo

2014-04-14 18:37

developer   ~0074392

Please test and close if ok.
Gtk2 (r44723) and Qt (r44724).
Will be merged to 1.2.2 if I get positive feedback until it's packaged.

Zeljan Rikalo

2014-04-14 20:17

developer   ~0074396

r44731 - Fixed regression, crash when popup window is shown over modal window.

Allan E. Registos

2016-06-29 03:05

reporter   ~0093403

Thank you for the fix.

People should use the DateTimeCtrls package as reported here:
http://wiki.freepascal.org/ZVDateTimeControls_Package

The package is included by Lazarus install by default and can be found at Lazarus IDE's toolbar's 'Common Control' tab, the name of the control is TDateTimePicker.

Issue History

Date Modified Username Field Change
2014-04-14 10:39 Allan E. Registos New Issue
2014-04-14 10:39 Allan E. Registos File Added: zvdt.tar.gz
2014-04-14 10:43 Allan E. Registos Tag Attached: "ZVDateTimeCtrls-1.4"
2014-04-14 10:43 Allan E. Registos Tag Attached: "ZVDateTimePicker"
2014-04-14 10:53 Zeljan Rikalo LazTarget => -
2014-04-14 10:53 Zeljan Rikalo Widgetset GTK 2 => GTK 2, QT
2014-04-14 10:55 Zeljan Rikalo Note Added: 0074385
2014-04-14 10:55 Zeljan Rikalo Assigned To => Zeljan Rikalo
2014-04-14 10:55 Zeljan Rikalo Status new => assigned
2014-04-14 18:37 Zeljan Rikalo Fixed in Revision => 44723,44724
2014-04-14 18:37 Zeljan Rikalo Note Added: 0074392
2014-04-14 18:37 Zeljan Rikalo Status assigned => resolved
2014-04-14 18:37 Zeljan Rikalo Resolution open => fixed
2014-04-14 20:16 Zeljan Rikalo Status resolved => confirmed
2014-04-14 20:17 Zeljan Rikalo Fixed in Revision 44723,44724 => 44723,44724,44731
2014-04-14 20:17 Zeljan Rikalo Note Added: 0074396
2014-04-14 20:17 Zeljan Rikalo Status confirmed => resolved
2015-10-22 13:38 Zeljan Rikalo Relationship added related to 0028863
2016-06-29 03:05 Allan E. Registos Note Added: 0093403
2016-06-29 03:05 Allan E. Registos Status resolved => closed