View Issue Details

IDProjectCategoryView StatusLast Update
0026062LazarusLCLpublic2014-04-24 02:03
ReporterJoachim PaepkeAssigned ToBart Broersma 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Platformi386OSLinuxOS Version3.2.0-4-686-pae
Product Version1.3 (SVN)Product Build44797 
Target VersionFixed in Version1.4 
Summary0026062: property ParentColor of TCustomEditButton
DescriptionTCustomEditButton has a property ParentColor.
TCustomEditButton is in fact derived from TControl. And TControl sets its own property ParentColor to true as default.
This results in having the Edit the color of the parent.
Steps To ReproduceJust take exmpale.zip from Report ID 0026057 and change the color of the form and see what happens. I dont think this is the intended behaviour.
Color of the edit changes in design and in runtime to color of the form.
TagsNo tags attached.
Fixed in Revisionr44800
LazTarget-
WidgetsetGTK 2
Attached Files

Activities

Bart Broersma

2014-04-24 00:23

developer   ~0074552

Please close if OK.

Joachim Paepke

2014-04-24 02:03

reporter   ~0074553

Is Ok
Thanks for fast assistance

Issue History

Date Modified Username Field Change
2014-04-23 22:48 Joachim Paepke New Issue
2014-04-23 23:57 Bart Broersma Assigned To => Bart Broersma
2014-04-23 23:57 Bart Broersma Status new => assigned
2014-04-24 00:23 Bart Broersma Fixed in Revision => r44800
2014-04-24 00:23 Bart Broersma LazTarget => -
2014-04-24 00:23 Bart Broersma Note Added: 0074552
2014-04-24 00:23 Bart Broersma Status assigned => resolved
2014-04-24 00:23 Bart Broersma Fixed in Version => 1.4
2014-04-24 00:23 Bart Broersma Resolution open => fixed
2014-04-24 02:03 Joachim Paepke Note Added: 0074553
2014-04-24 02:03 Joachim Paepke Status resolved => closed