View Issue Details

IDProjectCategoryView StatusLast Update
0026084LazarusWidgetsetpublic2019-04-22 19:33
ReporterMartin Friebe Assigned ToZeljan Rikalo  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Platformw32OSwin 
Product Version1.3 (SVN) 
Summary0026084: QT (on w32): scrollbar.Size returns wrong size
DescriptionSorry no simple case to reproduce.

With the latest IDE resize the width of the main IDE bar, You will see that it does not always wrap the component palette correct (there will be a horiz scrollbar at times)

In
ide\componentpalette.pas line 569 add

    DebugLn([ScrollBox.ClientWidth, ' ', ScrollBox.VertScrollBar.ClientSizeWithoutBar, ' ', ScrollBox.VertScrollBar.ClientSizeWithBar,
    ' size=',ScrollBox.VertScrollBar.Size
    ]);

You will notice (while resizing) that sive changes.

I get 30 (correct), 25 and 61 .

This leads to ScrollBox.VertScrollBar.ClientSizeWithoutBar returning to big a value. Because it takes the clientwidth and adds the Size (should be 30, but adds 60, which is to much.

TagsNo tags attached.
Fixed in Revision44831
LazTarget-
WidgetsetQT
Attached Files

Activities

Zeljan Rikalo

2014-04-28 09:10

developer   ~0074635

Please test and close if ok.

Issue History

Date Modified Username Field Change
2014-04-27 23:25 Martin Friebe New Issue
2014-04-27 23:27 Martin Friebe Summary QT (on w32): scrollbar.Sive returns wrong size => QT (on w32): scrollbar.Size returns wrong size
2014-04-28 08:05 Zeljan Rikalo Assigned To => Zeljan Rikalo
2014-04-28 08:05 Zeljan Rikalo Status new => assigned
2014-04-28 09:10 Zeljan Rikalo Fixed in Revision => 44831
2014-04-28 09:10 Zeljan Rikalo Note Added: 0074635
2014-04-28 09:10 Zeljan Rikalo Status assigned => resolved
2014-04-28 09:10 Zeljan Rikalo Resolution open => fixed
2019-04-22 19:33 Martin Friebe Status resolved => closed