View Issue Details

IDProjectCategoryView StatusLast Update
0026091LazarusLCLpublic2015-11-25 00:56
ReporterPaul NormanAssigned ToBart Broersma 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionunable to reproduce 
PlatformWindowsOSWindows OS Version8.1 Pro
Product VersionProduct BuildTyphon 4.8 
Target VersionFixed in Version 
Summary0026091: LCLIntf openurl() / LazHelpHTML - HtmlBrowserHelpViewer can not pass query string or anchor target
DescriptionThere have been a number of forum postings over the years identifying that under Windows at least, at some point a few years ago, it became impossible to pass anything more than a straight .html document path;

 blah.html?someting=this&somethingElse=that or even just blah.html#goHere
All fail to fully work, blah.html will open ignoring the query string or anchor target.

 THTMLBrowserHelpViewer.ShowNode passes the correct information to BrowserProcess (TProcessUTF8), BrowserProcess.CommandLine:=CommandLine;

But somewhere in BrowserProcess.Execute; query string and anchor target <filename->?... and <filename->#... all get lost.

This appears to happen under Windows where attempts to call BrowserProcess.execute are actually calling something like--

C:\WINDOWS\system32\rundll32.exe url.dll,FileProtocolHandler %s

Microsoft appear to have moved the goal posts on the use of url.dll, and this will not allow FPC anything after blah_blah.html file extension to be passed in %s.

LCLIntf openurl() and all kinds of direct system calls (apart from shellapi shellexecute() on Windows) all seem to also fail for parts of %s past the main file name.

Paul
Steps To ReproduceCovered in description.
Additional InformationThis sort of thing does works...

shellapi

shellexecute(0,
         pchar('open'),
         pchar(browserCommand) ,
         pchar(buildUrl ),'',0);

Workaround using a registry key, and more notes in ...

http://forum.lazarus.freepascal.org/index.php/topic,24347.msg146443.html#msg146443
Tagsopenurl
Fixed in Revision
LazTarget-
Widgetset
Attached Files

Relationships

related to 0021659 closedBart Broersma [Patch] OpenURL on Windows needs double quotes for file:// URL 
related to 0021637 resolvedReinier Olislagers HTML help with keyword containing # does not jump to anchor 

Activities

Bart Broersma

2014-04-29 12:22

developer   ~0074655

OpenUrl() is perfectly capable of opening urls like:
'https://www.google.nl/#q="foo bar" + fpc' or
'http://bugs.freepascal.org/view.php?id=25881'.

Note that OpenUL uses ShellExecute on Windows.

(Lazarus 1.3 r44839 FPC 2.6.4 i386-win32-win32/win64)

Reinier Olislagers

2014-10-24 15:58

developer   ~0078593

Please provide a compilable sample program that demonstrates this problem.

Reinier Olislagers

2014-10-26 13:59

developer   ~0078622

OpenURL apparently is NOT capable of opening file-based URLs with anchors; see issue 21637 (resolved not fixable).

As mentioned: it would be very nice to have an example program that demonstrates exactly what the issue is. The example in 21637 could perhaps be easily extended for this.

Bart Broersma

2015-11-24 18:11

developer   ~0087552

No feedback.
Re-open only if the issue is not resolved AND you attach a sample project (sources only) demonstrating the issue.
Otherwise close.

Issue History

Date Modified Username Field Change
2014-04-29 08:55 Paul Norman New Issue
2014-04-29 11:01 Jonas Maebe Project FPC => Lazarus
2014-04-29 12:22 Bart Broersma Note Added: 0074655
2014-10-24 15:58 Reinier Olislagers Note Added: 0078593
2014-10-24 15:58 Reinier Olislagers LazTarget => -
2014-10-24 15:58 Reinier Olislagers Status new => feedback
2014-10-24 15:58 Reinier Olislagers Tag Attached: openurl
2014-10-24 15:58 Reinier Olislagers Relationship added related to 0021659
2014-10-26 13:59 Reinier Olislagers Note Added: 0078622
2014-10-26 13:59 Reinier Olislagers Relationship added related to 0021637
2015-11-24 18:11 Bart Broersma Note Added: 0087552
2015-11-24 18:11 Bart Broersma Status feedback => resolved
2015-11-24 18:11 Bart Broersma Resolution open => unable to reproduce
2015-11-24 18:11 Bart Broersma Assigned To => Bart Broersma