View Issue Details

IDProjectCategoryView StatusLast Update
0026140LazarusIDEpublic2018-07-17 00:10
ReporternetdxrAssigned ToOndrej Pokorny 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformLinuxOSFedoraOS Version19
Product Version1.2.2Product Build44768 
Target VersionFixed in Version1.5 (SVN) 
Summary0026140: Source editor window jumps to top of screen when any tab clicked
DescriptionWhen using Xinerama with two different size displays, the source editor window will reposition to the top of the larger display when any source tab is clicked. This covers the normal position of the menu/toolbar and happens with both 1.2.0 and 1.2.2.
Steps To Reproduce- Start Lazarus and allow it to create a new, default ~/.lazarus directory
- Move the IDE menu/toolbar to the top of the larger screen and the source editor underneath
- Add a new unit to the empty project
- Click on either open tab in the editor
- The editor window will jump to the top of the screen and cover the menu/toolbar

A workaround is to place the menu/toolbar at the bottom of the larger screen. Moving the toolbar and source editor to the smaller screen works correctly.
Additional InformationThis issue happens on the larger screen in xinerama mode when two different size displays are used. In this case, one screen is a laptop at 1600x900 and the other is a 24 inch monitor at 1680x1050. The problem happens on the larger monitor but not the smaller laptop screen. Xdpyinfo shows a cumulative screen0 size of 3280x1050 pixels.

Manually positioning the edit windows on the larger screen, shutting down and restarting Lazarus doesn't restore the window positions also places the editor window at the top of the screen. A screenshot is attached showing a manually positioned edit window and the change after clicking the unit2 tab.
TagsNo tags attached.
Fixed in Revision50506
LazTarget-
WidgetsetGTK 2
Attached Files

Relationships

related to 0026051 closedMartin Friebe Lazarus Moves the code window after changing the active tab 
related to 0023839 resolvedOndrej Pokorny Packages Multi-monitor issue with project restore 

Activities

netdxr

2014-05-10 22:40

reporter  

ide-xinerama.png (72,142 bytes)
ide-xinerama.png (72,142 bytes)

Martin Friebe

2014-05-10 23:30

manager   ~0074897

Last edited: 2014-05-10 23:33

View 2 revisions

This (the tab click) may be a duplicate of 0026051 which is fixed in trunk

The restore on restart may be an additional issue. But check, what the restore setting for that window are, in the Menu > Tools > Options

Also check (via tools options) what the coordinates and size of the window are before and after

Ondrej Pokorny

2015-11-26 19:08

reporter   ~0087616

Double monitor issues should be solved now.

Issue History

Date Modified Username Field Change
2014-05-10 22:40 netdxr New Issue
2014-05-10 22:40 netdxr File Added: ide-xinerama.png
2014-05-10 23:30 Martin Friebe Relationship added related to 0026051
2014-05-10 23:30 Martin Friebe Note Added: 0074897
2014-05-10 23:33 Martin Friebe Note Edited: 0074897 View Revisions
2014-05-12 14:33 Martin Friebe Relationship added related to 0023839
2015-11-26 19:08 Ondrej Pokorny Fixed in Revision => 50506
2015-11-26 19:08 Ondrej Pokorny LazTarget => -
2015-11-26 19:08 Ondrej Pokorny Note Added: 0087616
2015-11-26 19:08 Ondrej Pokorny Status new => resolved
2015-11-26 19:08 Ondrej Pokorny Fixed in Version => 1.5 (SVN)
2015-11-26 19:08 Ondrej Pokorny Resolution open => fixed
2015-11-26 19:08 Ondrej Pokorny Assigned To => Ondrej Pokorny