View Issue Details

IDProjectCategoryView StatusLast Update
0026232LazarusIDEpublic2014-09-07 00:41
ReporterVbxlerAssigned ToJesus Reyes 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformWindowsOSWin7OS Version32/64
Product Version1.3 (SVN)Product Build 
Target Version1.4Fixed in Version1.3 (SVN) 
Summary0026232: stringgrid crash
DescriptionWhen in a Stringgrig only one row is displayed and the first (left) column has a width of 0, then the program crashes.
Steps To ReproduceChange in the IDE the value StringGrid2 -> Columns[0] -> Width to 0 and the program crashes.
Additional InformationIt seems that this error also affects the behavior of the IDE. The IDE is not as stable as before.
TagsNo tags attached.
Fixed in Revision46148
LazTarget1.4
Widgetset
Attached Files

Activities

Vbxler

2014-05-27 19:43

reporter  

Stringgrid_crash.7z (640,507 bytes)

Vbxler

2014-05-27 19:43

reporter  

Stringgrid_crash.png (22,090 bytes)
Stringgrid_crash.png (22,090 bytes)

Vbxler

2014-05-27 19:43

reporter  

Jesus Reyes

2014-05-31 20:34

developer   ~0075341

Cannot reproduce under linux/gtk2. Trying next windows.

Jesus Reyes

2014-05-31 20:49

developer   ~0075343

Same question, What Lazarus revision was used to reproduce this problem?, was it before or after fix 0026138 was applied?

Vbxler

2014-06-01 06:01

reporter   ~0075358

Lazarus 1.3; FPC 2.6.2; SVN 45183

This is after fix 0026138.

We have discussed this error on http://www.lazarusforum.de/viewtopic.php?f=5&t=7849 and they've this crash too. (with os win)

Issue History

Date Modified Username Field Change
2014-05-27 19:43 Vbxler New Issue
2014-05-27 19:43 Vbxler File Added: Stringgrid_crash.7z
2014-05-27 19:43 Vbxler File Added: Stringgrid_crash.png
2014-05-27 19:43 Vbxler File Added: Stringgrid_settings_columns.png
2014-05-27 20:09 Jesus Reyes Assigned To => Jesus Reyes
2014-05-27 20:09 Jesus Reyes Status new => assigned
2014-05-31 20:34 Jesus Reyes Note Added: 0075341
2014-05-31 20:49 Jesus Reyes LazTarget => -
2014-05-31 20:49 Jesus Reyes Note Added: 0075343
2014-05-31 20:49 Jesus Reyes Status assigned => feedback
2014-06-01 06:01 Vbxler Note Added: 0075358
2014-06-01 06:01 Vbxler Status feedback => assigned
2014-09-07 00:41 Jesus Reyes Fixed in Revision => 46148
2014-09-07 00:41 Jesus Reyes LazTarget - => 1.4
2014-09-07 00:41 Jesus Reyes Status assigned => resolved
2014-09-07 00:41 Jesus Reyes Fixed in Version => 1.3 (SVN)
2014-09-07 00:41 Jesus Reyes Resolution open => fixed
2014-09-07 00:41 Jesus Reyes Target Version => 1.4