View Issue Details

IDProjectCategoryView StatusLast Update
0026310LazarusPackagespublic2014-10-01 02:25
ReporterAlexey Tor.Assigned ToMartin Friebe 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version1.2.2Product Build 
Target Version1.4Fixed in Version1.3 (SVN) 
Summary0026310: SynEdit: more complete wordbreak list
Descriptionsynedittypes.pp
 TSynWordBreakChars = ['.', ',', ';', ':', '"', '''', '!', '?', '[', ']', '(',
            ')', '{', '}', '@', '^', '-', '=', '+', '*', '/', '\', '|','<','>'];

Need more chars, ok? Also:

`
~
%
&
#


TagsNo tags attached.
Fixed in Revision46389
LazTarget1.4
Widgetset
Attached Files

Activities

Martin Friebe

2014-10-01 02:25

manager   ~0077832

I added them, except for #

Those changes modify the behaviour of the IDE, and # affects pascal:

writeln(0000033#34#35 + 'aaa');

0000033#34#35 is currently one word, and people may find that useful (there is no right or wrong here, you can define, if you want to see this as one, or as 3 words)

I am aware, that in other languages (shell, perl) this is the comment marker, and for those it needs to be word break. But pascal and the IDE are more important at this time.

& affects html   from now on stops at the n, instead of the &, but that is minor enough, and therefore I added the change.


In any case, this is only a default, you can trace where it is used and assign different lists depending on the type of text.

The current solution is insufficient anyway, since it does not support utf8. However it is not yet clear how/when this will be solved.

Issue History

Date Modified Username Field Change
2014-06-09 00:57 Alexey Tor. New Issue
2014-06-09 07:56 Mattias Gaertner Assigned To => Martin Friebe
2014-06-09 07:56 Mattias Gaertner Status new => assigned
2014-10-01 02:25 Martin Friebe Fixed in Revision => 46389
2014-10-01 02:25 Martin Friebe LazTarget => 1.4
2014-10-01 02:25 Martin Friebe Note Added: 0077832
2014-10-01 02:25 Martin Friebe Status assigned => resolved
2014-10-01 02:25 Martin Friebe Fixed in Version => 1.3 (SVN)
2014-10-01 02:25 Martin Friebe Resolution open => fixed
2014-10-01 02:25 Martin Friebe Target Version => 1.4