View Issue Details

IDProjectCategoryView StatusLast Update
0026315LazarusLCLpublic2014-09-24 19:10
Reporterrobert83Assigned ToJesus Reyes 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformWindowsOSWindowsOS VersionWindows 7
Product Version1.2.2Product Build44758 
Target Version1.4Fixed in Version1.3 (SVN) 
Summary0026315: DBGrid horizontal scrollbar strange behaviour
DescriptionYou have a DBGRID with 2 columns, you resize column 2 to go beyond the width
of the DBGRID the horizontal scrollbar appears, you scroll to the end of the 2nd column, now you resize column 2 to it's original width, the horizontal scrollbar disappears, and you are stuck in a position in which column1 is only partially visible.
It only resets if you move up or down in the DBGRID.
Steps To Reproduce1. Add one DBGRID to form
2. Add 2 columns to DBGRID ( it works with any column numbers btw.)
3. Resize Column2 to exceed beyond the width of the DBGRID.width so that a horizontal scrollbar appears.
4. Scroll to the end of the Column2 (now column1 is only partially visible)
5. Resize column2 to original size , scrollbar disappears , you are stuck in a position where column1 is still partially visible...

* you need to move up or down in DBGrid to make it go to the start of the DBGrid again

I think that it should jump auto magically to the start of the DBGRID once you've resized column2 .
TagsNo tags attached.
Fixed in Revision45548
LazTarget1.4
WidgetsetWin32/Win64
Attached Files

Relationships

duplicate of 0019982 resolvedJesus Reyes Horizontal scrollbar bug in dbgrid 

Activities

Jesus Reyes

2014-06-16 08:27

developer   ~0075719

Please test.

Mike Thompson

2014-09-24 00:13

developer   ~0077573

Last edited: 2014-09-24 19:10

View 2 revisions

Original comment deleted. Issue is indeed resolved.

Issue History

Date Modified Username Field Change
2014-06-09 14:28 robert83 New Issue
2014-06-09 17:52 Jesus Reyes Assigned To => Jesus Reyes
2014-06-09 17:52 Jesus Reyes Status new => assigned
2014-06-16 08:27 Jesus Reyes Fixed in Revision => 45548
2014-06-16 08:27 Jesus Reyes LazTarget => 1.4
2014-06-16 08:27 Jesus Reyes Note Added: 0075719
2014-06-16 08:27 Jesus Reyes Status assigned => resolved
2014-06-16 08:27 Jesus Reyes Fixed in Version => 1.3 (SVN)
2014-06-16 08:27 Jesus Reyes Resolution open => fixed
2014-06-16 08:27 Jesus Reyes Target Version => 1.4
2014-09-24 00:13 Mike Thompson Note Added: 0077573
2014-09-24 08:40 Juha Manninen Relationship added duplicate of 0019982
2014-09-24 19:10 Mike Thompson Note Edited: 0077573 View Revisions