View Issue Details

IDProjectCategoryView StatusLast Update
0026354LazarusLazReportpublic2014-06-22 10:03
ReporterAlonso Cárdenas MárquezAssigned ToJesus Reyes 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platformamd64OSFreeBSDOS Version10.0
Product Version1.2.4Product Buildamd64 
Target Version1.2.6Fixed in Version1.3 (SVN) 
Summary0026354: Lazreport - Dessing report doesn't work on freebsd-gtk2
DescriptionOne error appear when I access to Design Report on frReport1 component that is on one Form

The following message is showing when I try to access the first time:

El editor de componentes de la clase "TfrRepEditor"
invocado con el verbo #0 "Diseñar report"
ha creado el error:
"Access violation"

When I try again it showing the following message

El editor de componentes de la clase "TfrRepEditor"
invocado con el verbo #0 "Diseñar report"
ha creado el error:
"TCustomForm.ShowModal for frDesignerForm:TfrDesignerForm impossible, because already visible (hint for designer forms: set Visible property to false)"
Steps To Reproduce1) Put TfrReport component on a Form
2) Try access to Design Report from frReport1 icon (mouse right click)
Additional InformationIt works fine when lazarus was compiled with QT interface
TagsNo tags attached.
Fixed in Revision45598
LazTarget1.2.6
WidgetsetGTK 2
Attached Files

Activities

Jesus Reyes

2014-06-22 10:03

developer   ~0075837

Please test.

Issue History

Date Modified Username Field Change
2014-06-18 06:37 Alonso Cárdenas Márquez New Issue
2014-06-20 02:54 Jesus Reyes Assigned To => Jesus Reyes
2014-06-20 02:54 Jesus Reyes Status new => assigned
2014-06-22 10:03 Jesus Reyes Fixed in Revision => 45598
2014-06-22 10:03 Jesus Reyes LazTarget => 1.2.6
2014-06-22 10:03 Jesus Reyes Note Added: 0075837
2014-06-22 10:03 Jesus Reyes Status assigned => resolved
2014-06-22 10:03 Jesus Reyes Fixed in Version => 1.3 (SVN)
2014-06-22 10:03 Jesus Reyes Resolution open => fixed
2014-06-22 10:03 Jesus Reyes Target Version => 1.2.6