View Issue Details

IDProjectCategoryView StatusLast Update
0026397FPCCompilerpublic2014-06-26 20:34
ReporterMathiasAssigned ToJonas Maebe 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionduplicate 
PlatformIntelOSWindowsOS Version7
Product VersionProduct Build45594 
Target VersionFixed in Version 
Summary0026397: inline error
DescriptionThis code:

procedure TBackGround.Draw; inline;
begin
  inherited Draw(Matrix);
end;

does not do the same as this one:

procedure TBackGround.Draw;
begin
  inherited Draw(Matrix);
end;

Without inline does my program.


The excerpt is from a code with multiple offspring a class.

original post:
http://www.lazarusforum.de/viewtopic.php?f=5&t=7547&p=70114#p70114
TagsNo tags attached.
Fixed in Revision
FPCOldBugId
FPCTarget
Attached Files

Relationships

duplicate of 0018121 resolvedJonas Maebe Illegal expression if inherited is used in inline method 

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2014-06-26 18:03 Mathias New Issue
2014-06-26 20:33 Jonas Maebe Project Lazarus => FPC
2014-06-26 20:34 Jonas Maebe Relationship added duplicate of 0018121
2014-06-26 20:34 Jonas Maebe Status new => resolved
2014-06-26 20:34 Jonas Maebe Resolution open => duplicate
2014-06-26 20:34 Jonas Maebe Assigned To => Jonas Maebe